Restore problem evaluating client for hypher-v 2016 problem

I decided to evaluate the special client for hypher-v 2016. The server is installed on a Cent Os server. It is version v2.3.8.0. The client version is 2.2.18-hypherv .

I made successful full image backup (in compressed vhdz format) of one of our servers. But I fail with restore.
According to the client documentation. I have 2 options using PowerShell scripts or Live restore by directly using disk from server.

Using the PowerShell script I managed hardly (with many read timeouts) to create a vhdx disk, which I attached to a new virtual machine. The problem is that the new disk seems to have corrupted file system. The system boot in recovery mode. checkdisk returns too many errors.

I tried the second option. I tried to assamble the vhdz but I receive the following error:

ERROR: MBR data version not supported: 100
Error while parsing MBR data

Also tried to use the live cd. Again I receive the error:
ERROR: MBR data version not supported: 100
Error while parsing MBR data

The guest system is Windows 2008R2.

Can you give me some hints ?

Thanks for trying and posting about your problems!

Could you post how one of these timeout errors looks?

You don’t need to assemble the vhds if they were backed up via hyper-v client. Uncompress them or use them directly if they weren’t compressed.

Thanks for the answer.
I will try to just decompress it

The read timeouts looks like this :

2019-09-27 14:18:24: Image load 20% complete
2019-09-27 14:19:27: Image load 21% complete
2019-09-27 14:20:27: Image load 22% complete
2019-09-27 14:21:03: WARNING: Read Timeout: Retrying
2019-09-27 14:21:03: WARNING: Read Timeout: Retrying
2019-09-27 14:21:34: Restoring to d:\2\CM-SRV-03_IDE_0_0.vhdx
2019-09-27 14:21:34: Image load 22% complete

And I am wondering , why I can’t restore backup with different client? In case of disaster recover it is good to can do it.
When I start the script from different hypher-v host with different client I can’t see the backups.
.\hyperv_list_backups.ps1 -VmName CM-SRV-03


Could you te

Did that work?

This is currently restricted on the server, plus I’d have to add a hyper-v server name parameter. I’ll consider adding that, since the restore cd can access that data anyway (but Internet clients can’t…).


I needed time to make some tests.

So the result is, that I have general problem to restore an image backup executed on hypher-V client. I repeat the tests 3 times and received the same results.

I did the following tests:

A Full image backup of an VM - Windows server (the client did a production snapshot). The backup image is stored as compressed image.

The restore process:
Bootable CD - not working solution ( as described in the manual )

PowerShell scripts - manege to create a VHDX disk. There were read time out errors during the process of transfer.
The restore was not successful. The windows system boots in recovery mode. Diskcheck returns too many errors.

I triyed to decompress the image locally on the backup server and then transfered the image to Hypher-V host. Again not successful the VM boots in recovery mode.

I didn’t test if the image is stored in VHDX format (uncompressed).
I didn’t test restore of incremental backups.


Unfortunately seems to be more of a backup problem, then.

Could you give me a few more details about the backed up VM? Disk type, size, layout, are there existing snapshots of the VM when the backup is started? Are snapshots removed/created during backup?

OK, I tested two servers:
The first one is a Domain Controller server. (I didn’t succeed to make backup. I suppose that the Guest OS doesn’t support production checkpoint features of the Hypher-V 2016. I couldn’t create a checkpoint using the Hypher-V Manegment console eather).

The second server I tested is a Windows Server 2008R2, which work as a SharePoint Portal. The backup process automatically creates a snapshot and after the end of the backup process the snapshot was removed.
The disk of the server is created as Dynamically expanding virtual hard disk (VHDX) 181 GB max size (180 GB current size)
The disk controller is IDE0:0

The version of the virtual machine is 8.