Restore Physical Backup to VMware Workstation - not local server found - solved

I set up my UrBackup on a Proxmox Server and was able to backup my Windows machines sucessful.
Now I wanted to test the restore process. As I have to reinstall my Notebook, I am trying to do the restore into a VM to be able to access the current settings in case I missed anything. I also would like to test the restore procedure every now and then to make sure backup and procedures still work.

I set a new VM in VMware Workstation with the network card as Bridged (Automatic).
When booting the Restore CD image I get an IP and also can ping my UrBackup server.
Unfortunately then the message “No local server found. Please configure Internet Server or ensure the server runs.”
Therefore I am lost at this point. Do you have hints how to fix this?

Server: UrBackup 2.4.13
Restore CD: urbackup_restore_2.4.0


Why is it always the same? Once you ask for help or sent a post to a forum, things work just smooth…
I did a reboot of the server and the rescue CD, chose textbased instead of GUI and the server was found.
I will see if I can boot the restored VM and give the GUI another try.

After rebooting client and server both, text and GUI based restore worked fine.
I can confirm that the versions mentioned above work fine.