Restore of MBR image over GPT disk fails

I’m validating my ability to do an image restore before completely trusting UrBackup. I used the 1.1.1 Restore CD (installed on a USB stick) to restore onto an old 500GB drive I have in a testing box. Tried installing Win 8.1 and Win 7 images, and while the actual restore finished without error, both restored images failed to boot with “Missing Operating System” errors. I booted into the Win 8.1 Recovery CD and tried running “bootrec /scanos” in the command prompt, but the restored OS wasn’t found. Booted into Linux on another drive in that box, and gparted said that the drive was GPT-formatted but was missing the MBR.

The drive I tried to install onto was out of a FreeNAS 9.3 RaidZ1 3-disk set, so it was GPT formatted. It looks like your restore procedure fails to wipe out all the GPT info when restoring an MBR image, so the BIOS can’t properly load the Win OS.

I was able to get around this by wiping the disk using ‘dd if=/dev/zero of=/dev/’ while in Linux. That wiped the GPT info, and I could then restore both the Win 7 and Win 8.1 images and get a bootable disk.

Thanks for the hint! Will check for GPT in sector 1 and null it if present in the next version.

You may have to rebuild the MBR first then attempt the restore. Download bootice (download according to VM OS, 32-bit or 64-bit) run it and select Disk Image Tab. Navigate to VHD file and select it. Then choose
1.Proces MBR
2.Windows NT 5.x/6.x MBR
4.Windows NT 6.x
5.Process PBR

This will build the MBR into the current VM. After you have recovered, use your installation media and perform bootrec /rebuildbcd to help the machine boot.