Restore failing for all client


I am using urbackup (with 10 urbackup client). Backup are running smooth but today when i tried restore of a file, it failed. First i thought restore is failing for just one client but on trying restore for other client i discovered that restore is not running for any client. Restore simply fails by giving below error:

2018-01-22 06:08:15: Starting restore of path “2.1.x_gitHub/putty-0.70-installer.msi”. Waiting for client confirmation…
2018-01-22 06:08:25: Starting restore…
2018-01-22 06:08:25: Loading file list…
2018-01-22 06:08:25: Calculating download size…
2018-01-22 06:08:25: Downloading necessary file data…
2018-01-22 06:08:26: ERROR: Error while downloading files during restore
2018-01-22 06:08:26: Restore failed.

Can anyone please tell me what is wrong here.

FYI, below are the permission of nfs share mount i am using for storing backup:

[root@urserver ~]# ls -lh /home/
total 14K
drwxrwxrwx. 17 urserver urserver 9.3K Jan 22 05:56 ntil_si

[root@urserver ~]# ls -lh /home/ntil_si/
total 362K
drwxr-x---.  10 urserver urserver 6.0K Dec 12 03:31 Anup-lap
drwxrwxrwx.  21 urserver urserver  12K Jan 22 04:42 client4
drwxr-x---. 102 urserver urserver  57K Jan 21 10:23 client5
drwxr-x---.   2 urserver urserver 1.1K Jan 10 11:52 client_8_166
drwxrwxrwx.   2 urserver urserver 7.1K Jan 22 05:57 clients
drwxr-x---.  84 urserver urserver  47K Jan 22 05:57 clientW275
drwxr-x---.  17 urserver urserver 9.9K Jan 22 01:41 clientW4157
drwxrwxrwx. 108 urserver urserver  60K Jan 22 02:08 DLDT-1279
drwxr-x---.   3 urserver urserver 2.2K Jan  8 00:41 localhost.localdomain
drwxr-x---.   2 urserver urserver  25K Jan 21 07:55 urbackup
drwxr-x---.   2 urserver urserver 1.1K Jan 22 05:57 urbackup_tmp_files
drwxrwxrwx.  63 urserver urserver  35K Jan 22 05:06 WIN-29CJEVO4MRB
drwxrwxrwx.  61 urserver urserver  34K Dec 27 10:23 WIN-SB1KEMIHQVC


What happen is that you get a timeout for a pop up, to confirm a restore on a computer that may not have a gui.

My personal suggestion is to to use the server-confirm (please read doc) option on the client, then only start restores from the web ui.


I have a gui and I got a confirmation box stating if i want to restore particular file at client side and i clicked “yes”, but still restore failed.


I solved the issue by running urbackupsrv daemon by root user. But i still cannot understand why client folder in storage path is having permission for urserver user in place of urbackup user.


That’s weird. Could be unconnected.

To solve the problem the client (debug) log would be useful.
If possible, could you post it or send it?

This post describes how to change the client to debug logging, where it is stored and where to send it to if posting is not possible: Having problems with UrBackup? Please read before posting


split this topic #6

A post was split to a new topic: File restore fails with permission error