Restore Client 2.4.2 not seeing NVME drive

I’m trying to restore to a machine with an NVME drive using the latest urbackup restore client 2.4.2. (Just downloaded.) The drive is not seen by the graphical interface or the text interface. Looking through the forums, I saw the suggestion of turning off Secure Boot in BIOS. Unfortunately, this is not an option on the latest Dell computers. (“Legacy boot is not supported on this platform.”)

To solve this particular instance of this problem, I can get a SATA SSD, restore to it, and make the NVME drive a second disk. However, I can’t do this for all my future machines.

Did I miss a solution somewhere?

I’d start with googling Laptop model + Linux NVMe.

Does lsblk list it? Ist there info in dmesg about it?

Rebooted to the restore graphical client and opened a terminal. lsblk doesn’t see it and dmesg says “Operation not permitted.” It’s quitting time, so I’ll boot xbuntu live tomorrow so I have root. I’ll let you know.

OK, the problem is not with NVMe drives, the problem is with Intel Rapid Store Technology being enabled in BIOS. Once I switched it off, the URBackup Restore environment can see the NVMe disk without a problem.

Ubuntu has a pretty complete write up on the issue. (Which is how I discovered the issue. Xubuntu live environment couldn’t see the drive either, so I attempted to install xubuntu and it pointed me to this writeup: Intel RST )

I finished the first half of the instructions on that page, making changes to the registry before I switched to AHCI mode in the BOIS. Windows 10 won’t boot now, so I have some steps to take before I try the restore.

I will update as I go along.

To Busy To Read The Whole Thing Summary:
(Works on a Dell Precision 3650, your mileage may vary.)

  1. Insert the URBackup Restore CD/USB Drive
  2. Boot to BIOS
  3. In the Storage category, switch from Intel Rapid Storage Tech (RAID On) to AHCI
  4. Enable boot from the CD/USB Drive
  5. Boot to the URBackup Restore client and restore per instructions
  6. Shut down the computer and remove the CD/USB Drive.
  7. Boot to BIOS
  8. Switch Storage from AHCI back to Intel Rapid Storage Tech (RAID On)
  9. Reboot to a restored Windows 10.

This morning I tried the rest of the ubuntu instructions mentioned in this thread without success. The volume couldn’t be activated, and there was no safeboot value for bcdedit to delete. Instead of trying to manually create a new bootloader file with bcdboot, I decided to try the method above, and it worked for me.

1 Like

Same as here then, I guess

I think it would work on Linux with either dmraid or mdadm. It would be great to have it detect such a fake RAID automatically. But without having the actual hardware to test on I cannot do that, so I guess someone with it has to add it.