Restore CD shows "Authentication error" on a Sony Vaio laptop

Hi everyone,

I am trying to restore a full disk backup of a Windows 10 EFI laptop.
Sony Vaio to be specific - I can provide the exact model if needed.

I have created a bootable USB stick with a few tools, including the “Restore CD 2.1.1 (x64)”, using YUMI. I have selected “Debian” as an OS type when adding the “Restore CD” image to the USB stick.

I can boot the “Restore CD” up to the point when it asks for the user name and password. But, instead of booting further the only thing I see is a completely empty screen with a cursor in the upper left corner. When I press Ctrl+Alt+Fn to switch between the consoles, I can see a login prompt followed by “urbackup (automatic login)” followed by an “Authentication error” message. It shows for half a second and then erases the screen, so that it is completely blank again.

Pressing Ctrl+Alt+Del correctly reboots the system. It stops all the processes and restarts.

The problem is that I can not do anything, as the login prompt is not really there, and the automatic login fails. Any suggestions are greatly appreciated, as I am a bit unsure how can I restore the machine now.

I have tried urbackup_restore_2.3.0.iso, but it fails to load at an earlier stage.
I see messages about the discovered USB devices, then there is a long delay, a minute or two.
And then it shows a “BOOT FAILED!” message, like this one: Restore CD 2.3.0 beta

Does the official Debian live cd boot?

Also what kind of usb stick are you using. See e.g. (tails seems to use debian live as well)

I’ve made some progress. Will record here the details in case someone else will be in a similar situation.

The official Debian live CD boots. (I have also tried Ubuntu 19.04 with also boots)

I was able to boot the Recovery CD version 2.2.2 successfully.
It up to the urbackup user prompt. But did not start the recovery process.
I had to do

sudo su -

Yet, it was not able to scan the Wi-Fi networks from the CUI. So I had to configure Wi-Fi “manually”, on another console (Alt+F2):

vim /etc/network/interfaces
allow-hotplug wlan0
iface wlan0 inet dhcp
:r !wpa_passphrase <ESSID>
[type the wifi password]

Adjust the output to look like this:

allow-hotplug wlan0
iface wlan0 inet dhcp
       wpa-essid [ESSID]
       #wpa-pwd "your password"
       wpa-key [base64 encoded key]

Start the WiFi interface:

ifup wlan0

Then went back to the CUI of the restore process (Alt+F1) and was able to connect to the server and recover the data, by following the “wizard” dialogs. The disk uses GPT, and the recovery process showed that it has recovered the GPT partition table.
But the system did not boot correctly after a reboot. Maybe I need to tweak a few things - will try tomorrow.