Restore CD: create new partions from free space

Hi, i have a strange issue with the Restore CD.
Usually, when i burn a ISO (for example, Clonezilla) i created also a new partition on the space left on the USB storage. This is very useful because i can use the USB storage as a live cd and a mass storage at the same time.
I did it using “balena Etcher” and after writing the image, i create a new partition via fdisk or similar.

With the urbackup restore cd iso this is not possibile. I burn the iso with “balena Etcher” but fdisk can’t allow me to create a new partition.
I’ve tried also with Rufus and the result was the same.


I’ve tried also the old versions and there are the result:

urbackup_restore-2.0.3-2-amd64 works (balena etcher + new partition on the free space)
urbackup_restore-2.1.1 works (balena etcher + new partition on the free space)
urbackup_restore_2.2.0 doesn’t work
urbackup_restore_2.2.2 doesn’t work
urbackup_restore_2.3.1 doesn’t work

So i guess the issue starts with the 2.2 restore cd. Now i will try to check the mods between the 2.2 and the 2.1.1 and i will let you know.

@uroni i saw that the repository starts from 15/7/2019. Where can i find earlier version of restore_cd?

@uroni could you please point me to the modifications about the urbackup_restore_cd in order to fix this issue?

i’ve submitted also a post in the balenaEtcher forum

I solved myself:

Great! If you wanto help further, tell the debian live-build team about this after checking this issue is still present ( UrBackup is build like this ).

Clonezilla also seems to use debian live build, but perhaps doesn’t support efi yet?

Hi @uroni, clonezilla supports EFI, but is build without using the config files: it use the options of lb config, i think there is a way to remove the second partition in urbackup too.

Good idea to post it to the live-backup group, maybe they could do something about it.

Posted here: