[Resolved] Win 7 urbackup client not connecting to Win 2008 r2 urbackup server

Hey there.

As the title of the topic says, i have Win 7 urbackup clients on the same network as the Win 2008 r2 backup server, but the clients aren’t picking up the server. They were able to at one point, but now they haven’t been able to for months now. I’m able to reach the web interface though.

Any ideas as to why this is happening and what i can do to troubleshoot?

To further narrow down the problem you could:

  • Disable the firewalls on client and/or server
  • Have a look if the server and clients are still in the same network
  • Any new active switches which do not forward broadcasts?
  • Trace the broadcasting traffic via e.g. Wireshark. Broadcasts are sent from port 35623 UDP on the server to port 35622 UDP on the clients
  • On the status page via “show/hide column” enable the status column and then press “show all clients” and have a look at the status

Sorry for the long time before replying, but here’s the results of your points

  • Firewall is managed by Eset, disabled for 30 minutes and then restarted the urbackup service, and still nothing.
  • Server and client on the same network. Can ping the server from client, can ping client from server.
  • No new active switches.
  • All clients on the status page show as ok.
  • Will be checking the broadcast traffic a little later. Edit: Just ran a capture on a client, and it’s receiving packets from the server.

So it is receiving but not sending back? Baring errors in c:\Program files\UrBackup\debug.log something must be filtering the broadcast packets then.

Probably won’t work but you could also try to add one client’s IP as “extra client” on the status page to see if unidirectional casts reach the client.

Ran another capture, and it looks like it’s sending back as well.

Tried adding a client as an extra client and still nothing.

Ok, so I upgraded both the server and client to the latest versions and I can now add the clients manually, so that’s this problem solved.