References To Old Backup Location Persist

When I first started tinkering with UrBackup server (running as Ubuntu VM), I set the backup storage path to a mounted NAS. Later, I decided that was too slow and just changed the backup storage path in the settings to a local path and went through and manually deleted my backups (via the browser interface and then on the NAS). New clients started backing up to the new path and everything seemed fine.

Weeks later, as I’m trying to bring new clients online, some of their backups are failing and the error logs mention not being able to access a directory on the old backup storage path, which does not exist anymore. Other clients continued to back up as expected. Now, today, every backup is failing with the same error message although actual backup data still seems to be intact and inplace via the browser.

To resolve this, I’ve tried:

  • Running the urbackupsrv remove-unknown command

  • Using the migration feature to tell the server to migrate to the new/current backup storage path, then ran urbackupsrv remove-unknown

  • Using the urbackupsrv cleanup --amount x command followed by the urbackupsrv remove-unknown command

  • Plenty of reboots in-between

Before I just wipe the server and start over clean, does anyone have any other ideas as to how I could remove any straggling references to the first/old backup storage path?

Found the file /etc/urbackup/backupfolder whose contents contained my first backup storage folder path. I edited it to be my current one and backups began running again.

Before I fixed this, image backups were working correctly but file backups were not. But if anyone else ends up in this same state, the above is what fixed it for me.