Raspian Buster install

Trying to install the arm build for Debian on my nice new shiny Rpi 4, but I am having issues with dependencies.
Command used to download install package.
wget http://sourceforge.net/projects/urbackup/files/Server/1.2RC/urbackup-server_1.2-1_armhf.deb/download

Here is the output when I try to install the Deb package:

Preformatted text(Reading database … 123307 files and directories currently installed.)
Preparing to unpack download …
Unpacking urbackup-server (1.2.0.130-1) over (1.2.0.130-1) …
dpkg: dependency problems prevent configuration of urbackup-server:
urbackup-server depends on sqlite3; however:
Package sqlite3 is not installed.
urbackup-server depends on libboost-python1.49.0 (>= 1.49.0-1); however:
Package libboost-python1.49.0 is not installed.
urbackup-server depends on libcrypto++9; however:
Package libcrypto++9 is not installed.
urbackup-server depends on libcurl3 (>= 7.16.2); however:
Package libcurl3 is not installed.
urbackup-server depends on python-matplotlib; however:
Package python-matplotlib is not installed.

dpkg: error processing package urbackup-server (–install):
dependency problems - leaving unconfigured
Processing triggers for systemd (241-7~deb10u2+rpi1) …
Processing triggers for man-db (2.8.5-2) …
Errors were encountered while processing:
urbackup-serverPreformatted text

Sqlite3 installs. Libboost-pythoi can’t be found. libcrypto++9 cannot be found. libcurl3 is out of date and libcurl4 is installed. And python-matplotlib is found but does not install due to a tone of dependanices missing.
python-matplotlib output
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
python-matplotlib : Depends: python-backports.functools-lru-cache but it is not going to be installed
Depends: python-dateutil but it is not going to be installed
Depends: python-matplotlib2-data (>= 2.2.3-6) but it is not going to be installed
Depends: python-pyparsing (>= 1.5.6) but it is not going to be installed
Depends: python-tz but it is not going to be installed
Depends: libjs-jquery-ui but it is not going to be installed
Depends: python-cycler but it is not going to be installed
Depends: python-kiwisolver but it is not going to be installed
Depends: python-subprocess32 but it is not going to be installed
urbackup-server : Depends: libboost-python1.49.0 (>= 1.49.0-1) but it is not installable
Depends: libcrypto++9 but it is not installable
Depends: libcurl3 (>= 7.16.2) but it is not installable
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

Any ideas? Am I trying to install the wrong deb package?

Ron have you run apt --fix-broken install or apt -f install? It should install all the dependencies referenced.

The problem is more that the version used on the “new shiny Rpi 4” is 7 years old.

How did you even get the idea to install that version?

I think I wasn’t paying attention to the data on a how to site. Ended using this post:


And it installed just fine.