Quota enforcement bug

While waiting for 2.x to come out of beta, we still have 1.4.13 running and we just ran in to a strange quota enforcement bug. This particular machine runs at around 80% deduplication and is an older system with 4.25TB backup volume. We now have a client that has backup totals over 4.25TB and is getting quota enforcements regardless of the fact that there is 1.82TB free on the drive.

Is there a way to change quota enforcement so that it can be disabled? I currently have it set to 100%, so that quotas should not be enforced. But, this drive still has a fair amount of free space but is still getting quota enforcement errors.

You can either set it to empty or to something large like 100T.

As a follow up, I tried setting it to both a blank value and 100TB and for both of them it has continued to enforce the quota.

Sorry, seems it uses the global setting if the client specific one is empty and limits the maximum size to the size of the backup storage.

So the only work-around would be to set it for all clients (globally) to empty and locally as well.

I’ll have to release a new version with a fix.

Well, there are no client specific settings for that machine. I was using the global settings. Hope that helps to find the error in logic.

In fact, I do not limit any client on that machine with quotas. Even with global settings at 100%, empty or set to 100TB, it still enforces a quota at 4.25TB for that machine because of the disk size, even though there is 2+TB of free space on the drive due to deduplication.

Thank you for your time.