Question about Nightly Clean-up

Using UrBackup Server 2.4.12 on Windows Server 2008 (for this week) with Client 2.4.10 on Windows 7 (for another day or so).

Watching the live log for the Nightly clean-up, I spotted something I’ve wondered about before. The Debug message refers to Max file backups but the value is from the Min field.

|02/24/20 02:54  |DEBUG  |Client with id=22 has 1 full file backups max=1|
|02/24/20 02:54  |DEBUG  |Client with id=22 has 4 incremental file backups max=1|
|02/24/20 02:54  |INFO  |Deleting incremental file backup ( id=9600, backuptime=2019-08-24 04:31:04, path=190823-2330 ) from client "NECD-L14" ( id=22 ) ...|
|02/24/20 02:54  |INFO  |Done.|

The Settings for the Group, of which this client is a member, are:

If this pass is deleting backups because clean-up thinks the Maximal number is 1, then that is an error which should be fixed. If it is seeking additional space and really means there are more than the Minimal number so OK to delete, that is just a typo of Max for Min and can be deferred as a cosmetic fix. I would like to see the reason for the deletion on the Info Deleting incremental file backup line, even if just a shorthand note like “Rule 4: Deleting…” with the meanings listed in the admin manual.

Do you have client specific settings enabled? Maybe you have max incremental file=1 on client settings and those (as i understand) come before global settings.

Good guess, but not on this client. All settings are declared from the server side and are common to the Group, as shown.

I just came back to the forum looking for this exact topic. Amazingly, it was at the very top of the list and I didn’t even need to search! Now THAT’s service. LOL!

Exact same issue and exact same question.
UrBackup Server v2.4.11 running on Windows Server 2012R2

Client specific settings aren’t the issue on mine either.

One would have to look at the complete log of the cleanup. E.g. if there is a global soft file system quota, there’ll be a line with Space to free: XXGB and after that it’ll use the min values as the limit used for cleanups.

I’ll have to monitor to see if this resolves my version of Don’s problem, but I definitely had my global soft file system quote set incorrectly. As often as I’m referring back to the manual, monitoring my server’s status, and reviewing my UrBackup config, I still managed to configure that particular setting poorly!
I re-re-read the description for that particular setting and realized that I’ve misunderstood it right from the start and for a very long time. Thanks for drawing my attention back to it.

Edit: Confirmed. Global Soft File System Quota was set too low, causing the Min value to be used instead of the Max value. Correctly configuring the quota resolved my version of Don’s problem. Hopefully, his is caused by the same issue.