Problem with restoring files backup on a new computer

Here is my setup:
Ubuntu 20.04 LTS server, UrBackup server 2.4.13
Ubuntu 20.04 LTS server, UrBackup client 2.4.11

I’m trying to restore an old backup from a first client (no more accessible in my scenario) to a new client on a new computer.
I downloaded “client for linux” from the server, change the hostname on the client to match the old client, launched the sh script on the new client.
Then, when i tried to restore a backup with: sudo urbackupclientctl restore-start -b 1
This command give the error: Error getting file backups
I found in the forum a fix with copying tokens. So, i deleted usr/local/var/urbackup/tokens/* to put there files from the first client.
When i tried to restore once again, no more errors, got the message “Restore completed successfully” but nothing is restored.
And this command: sudo urbackupclientctl browse give me only the new backups but not the old ones i try to restore.
Can you help?

Did you download the SH file of the old urbackup client?

Disconnect the old host and try again on the new host.

Thanks for your reply.

I made a new try:

  • Install a new client A
  • Doing a backup
  • Download the sh script for installing the client A
  • Shutdown client A
  • Install client B, changing hostname for the same as client A, and launch sh script of client A
  • Try restoring backup of client A on client B => Success message but still no files

Here is the log in /var/log/urbackupclient.log:
Starting restore…
Loading file list…
Calculating donwload size…
Downloading necessary file data…
Applying file metadata…
Restore finished successfully.

In server UI, it says "Starting restore of path “”…
Why is the path empty?
I tried then to setup the same backup path for client B, but still not working.
What’s wrong in my actions ?

I’m still looking for solutions in this problem.
I tried to restore a backup made by the new client, and it’s working fine only with “urbackupclientctl restore-start” command. From server it’s not working.
But still trying to recover the first backup and it doesnt work.
Here is the log files:
urbackupclient.log (41.3 KB) urbackup.log (14.3 KB)

any ideas?

Finaly, it works by overwritting new client tokens with old ones.