Problem with excluding files

I have problem with backup configuration.
I’m trying to exclude mp3, avi and other media files from backup.

On server (Windows, version 2.4.13) I’ve included some kid of files - look at screen:

On client - all options are grayed - look at screen:

But on full/incremential backup all files are sended to server !
Part of log file:

04.03.21 15:58 DEBUG PT: Hashing file “10 Ścieżka 10.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “11 Ścieżka 11.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “12 Ścieżka 12.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “14 Ścieżka 14.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “15 Ścieżka 15.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “16 Ścieżka 16.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “02 Taka Warszawa - Beata.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “03 Lato jak ze snu - Beata.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “04 Kłamstwo - Magda Femme.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “05 Niebo - Magda Femme.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “07. Chciałbym Ci Powiedziec.mp3”
04.03.21 15:58 DEBUG PT: Hashing file “desktop.ini”
04.03.21 15:58 DEBUG PT: Hashing file “desktop.ini”
04.03.21 16:00 DEBUG HT: Copying file: “E:\ServerFolders\UrBackup\lewandowski-p\210304-1514\Desktop\Marian\MojeDokumenty\Nowy folder\Kin.avi” (id=310)
04.03.21 16:00 DEBUG HT: Renaming file to “E:\ServerFolders\UrBackup\lewandowski-p\210304-1514\Desktop\Marian\MojeDokumenty\Nowy folder\Kin.avi” with hash output
04.03.21 16:00 DEBUG Saved metadata of 289 files and directories. 9% done…

Please help me, how to configure free version of UrBackup because some people have mp3 files on their computers and I don’t want do have them on server.

Could you post a screenshot of this whole page? Thanks!

Of course.

  1. Server settings:

  2. Client default settings:

Excluded files path (default):
C:\ProgramData\Microsoft\Network\Downloader*;C:\WINDOWS\system32\LogFiles\WMI\RtBackup:.:;C:\Users\Administrator\index.dat;C:\WINDOWS\Minidump*;:\Pagefile.sys;:\System Volume Information\MountPointManagerRemoteDatabase;C:\WINDOWS\netlogon.chg;:\hiberfil.sys;:\System Volume Information\Heat*.;C:\Users\ADMINI~1\AppData\Local\Temp*;:\System Volume Information*{3808876B-C176-4e48-B7AE-04046E6CC752};:\System Volume Information:.{7cc467ef-6865-4831-853f-2a4817fd1bca}ALT;:\System Volume Information:.{7cc467ef-6865-4831-853f-2a4817fd1bca}DB;C:\ProgramData\Microsoft\Windows\WER*;C:\WINDOWS\softwaredistribution*.;:\System Volume Information\FVE2.{e40ad34d-dae9-4bc7-95bd-b16218c10f72}.:;:\System Volume Information\FVE2.{c9ca54a3-6983-46b7-8684-a7e5e23499e3};:\System Volume Information\FVE2.{24e6f0ae-6a00-4f73-984b-75ce9942852d};:\System Volume Information\FVE2.{9ef82dfa-1239-4a30-83e6-3b3e9b8fed08};:\System Volume Information\FVE2.{aff97bac-a69b-45da-aba1-2cfbce434750}.:;:\System Volume Information\FVE2.{9ef82dfa-1239-4a30-83e6-3b3e9b8fed08}.:;:\System Volume Information\FVE.{e40ad34d-dae9-4bc7-95bd-b16218c10f72}.:;:\System Volume Information\FVE.{c9ca54a3-6983-46b7-8684-a7e5e23499e3};:\System Volume Information\FVE.{9ef82dfa-1239-4a30-83e6-3b3e9b8fed08};C:\Windows\system32\MSDtc\MSDTC.LOG;C:\Users\Piotr\index.dat;C:\Users:\AppData\Local\Temp;C:\Users:\AppData\Local\Microsoft\Windows\Temporary Internet Files;C:\Users:\AppData\Local\Google\Chrome\User Data\Default\Cache;C:\Users:\AppData\Local\Google\Chrome\User Data\Default\Media Cache;C:\Users:\AppData\Local\Microsoft\Windows\Explorer\thumbcache*;C:\Users:\AppData\Local\Microsoft\Terminal Server Client\Cache;C:\Users:\AppData\Local\Mozilla\Firefox\Profiles:\cache2;C:\Users:\AppData\Local\Mozilla\Firefox\Profiles:\cache;C:\Windows\Temp;:$Recycle.Bin;:\System Volume Information;C:\Windows.old;C:$Windows.~BT;C:\ProgramData\Microsoft\Windows Defender\Scans\mpcache-*

1 Like

Any solution to this? I have the same problem.

It seems that the default exclude list overrides my custom one.

1 Like

same here. put this into Exclude files on the server (CentOS 7, 2.4.15):
and still have those folders in the log of backup attempts:

Error getting complete file "km81sz06LwBfNWZDwQuW|D/Private/Dropbox (SCT Operations)/.dropbox.cache/qebcobkqbgpbzfynfuwbof/placeholder.aep" from USERPC. Errorcode: CANNOT_OPEN_FILE (3)

According to its date, the file C:\Program Files\UrBackup\urbackup\data\settings.cfg was updated right before the backup, but no “dropbox” mentioned in it.

I did have a similar problem (excluding the steam library with *\Steam*
and what i have found is that if i add the exclude filter to an existing client. It’s seems that the exclude dosen’t work. but all new client will exclude the file.

Can you delete the client, re-add it and confirm that you have the same “problem” ?

I was adding paths to exclude on the server and that didn’t work, so I ended up with copying that paths to the client app settings.

Once the client has pulled the config from the server, I find that things like exceptions stay at the client side, and subsequent server changes don’t trickle down to existing clients.


Thank you for the explanation! This looks to me as a miss, b/c of the centralized nature of Urbackup. Is there a way to push the new settings from the server to clients?

The new (v2.5) version of UrBackup under development is aiming to address this issue with configuration…

For now, it is hit or miss, and mostly involves applying the policies via client config on the server-side

1 Like