Problem while restoring an image via VM

Nice project!

I have the following situation/problem:
My host system is a MacBook Pro (Mac OS X 10.7.3) with VMware Fusion 4.1.1.

UrBackup-Server and -client are running on the bootcamp partition (which i can access to with VMware Fusion) with Win 7 x64 SP1. I’ve made an image of that same partition with Urbackup, which worked fine.

Now i want to restore that image into an empty virtual machine which i created on the same host system. Knoppix boots fine, so does Urbackup. During the process it finds the UrBackup-server and the image i made, but when trying to restore it hangs with “Teste Partition auf Verfügbarkeit”. I guess the routine isn’t able to locate/handle the partition/virtual disc inside the empty VM.

I tried to fix that via fdisk, GParted and even the Win 7 Setup-disc. I ran the setup until the part, where i could create the partitions and then aborted the setup. But none of these methods solved my problem.
Do you have any idea or solution for me?

You can answer in German, if you want. Thanks in advance! :-)

What it does is it writes the MBR it saved back onto the disk and then instructs the kernel to reread the partition table. If it does not find the saved partition after that it hangs after that.

Two things that may be the problem:

  • GPT tables are not supported yet
  • Logical volumes may cause problems

Is the partition one of the above?

[quote=“uroni”]Two things that may be the problem:

  • GPT tables are not supported yet
  • Logical volumes may cause problems

Is the partition one of the above?[/quote]

I would guess no.

If you know a little bit about linux you can

  1. Somehow restore the partition table (if the CD did not already do that)
  2. Restore the vhd content by mounting the server folder, intalling the server (e.g. with the .deb in knoppix) and then restoring the VHD with
    urbackup_srv --plugin /usr/lib/ --vhdcopy_in /path/to/image.vhd --vhdcopy_out /dev/sda1

I’d very much like to find out what is not working though. Could you send me the .mbr file please? (It does only have the partition table and the partition name and number in it) (To Thanks!

Mail is sent.

Same happens to me on a real PC:

  • did a full image backup of a notebook
  • did 2 additional incrementell backups
  • swap out old HDD against a fresh and bigger (500GB) HDD
  • restore via restore CD
  • throttling printing message “Teste Partition auf Verfügbarkeit”

It doesn’nt matter if I restore the first full image or the 2 additional images. If I run gparted afterwards it brings me the message “Invalid partition table on /dev/sda – wrong signature 0.” If I hit Ignore, I can see a couple of partitions in gparted.

Any ideas?



other people had luck with a never image with a newer Linux kernel. Can you try that one as well?

Shame, I had no luck restoring the full backup.

This is what happens:

Loading MBR for hard disk
Reading MBR...
Writng MBR...
Reading partion table...
Testing partition table availability...
--- above message repeats about 10 times---  

A new dialogue pops up:

Following error happend: Restore partition not available. How to continue?
r Restart restore
s Stop restoration  

I really hope to find a solution. UrBackup is just the solution I’m looking for…

Can you send me the .mbr file of the image, that isn’t working?
The email address is

You’ve got mail…

Thanks! I think I found the issue. It was the extended partitions you had. Linux did not like the way UrBackup restored them. The new image now automatically fixes the EBR signatures:

That part needs to support volumes on extended partitions and GPT partition tables at some point. Currently those volumes cannot be restored.

Thanks, the latest restore CD 1.0WIP3 seems to fix the partition restore problem.

However I ran into another problem during the restore process (now running server v1.1). The process stops at about 35% of the restore. On the client I get following selection:

r  Restart restore
s  Start shell
o  Restore other volume
s  Stop restoration  

If I try restart the restore a message blinks up. I need to press “r” repeatedly to see what it shows:

<DATE> <TIME>: ERROR: connection timeout  

I checked the HTTP-IF and found everything working. /var/log/urbackup.log, /var/log/messages, /var/log/syslog gives me no information about anything failed.
After I restart the server on the console I’m able to restart the restore - which again fails.

Could it be a memory problem? I’m running UrBackup in an OpenVZ container. Meanwhile I gave the VZ 4GB RAM which it eats up totally during the restore.
Any other hints?

During the restore you could switch to the shell (console) with ctrl+alt+F2 and enter

sudo su
cd /root  

and then

tail -f restore_mode.txt  

would show you the log messages during a restore.


would give you the memory/CPU usage of the running processes.

There should be a error message “Following error happened: [x]” above the choices. Do you remember which one that was?

Hi Martin,

wasn’t able to do too much testing today. So I did only one restore - which simply worked - funny. During the restore I switched between PS1/2 and was tailing the mentioned log - nothing special from my point of view.

On monday I’ll be able to do some more testing and report back. Meanwhile I just wanna ask if the restore problems could have had something to do with the server upgrade von v1.0 to 1.1. I was thinking that maybe the overnight cleaning procress cleaned up something in the way. What do you think?


Hi Martin,

I did a couple of successful restores now and did not encounter any errors. I’ve no idea why the first restores failed - however now it just works seamless.


Hi Martin,

intentionally today I wanted to recreate the extended partition. Under Windows 7 x64 I was not able to create or modify any partition. Windows was complaining about an invalid partition table. For the partition layout, which Windows 7 was showing, see attached file (had to zip the image to be able to upload it here).

The same info about an invalid partition table I got from gparted live cd. However this is the layout fdisk -l shows:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xdcdb1974  

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048     2459647     1228800    7  HPFS/NTFS/exFAT
/dev/sda2   *     2459648   125339647    61440000    7  HPFS/NTFS/exFAT
/dev/sda3       125339648   604659711   239660032    f  W95 Ext'd (LBA)
/dev/sda4       604659712   625139711    10240000    7  HPFS/NTFS/exFAT
/dev/sda5      3071838208  3071847234        4513+  4c  Unknown   

Hope you have another idea :)


I still had a virtual disk with your partition table here, so I tried it in a Windows XP VM and I could just delete the extended Partition (and afterward recreate it) in Windows.

But if you are already in fdisk, can’t you remove it there? It’s /dev/sda3 in your case. I’d remove /dev/sda4 as well.

Hi Martin,

worked like a charm using fdisk to delete sda3 and sda4. After a reboot Windows was able to read the partition table and delete sda1 as well.

I don’t know why neither Windows nor gparted was able to read the partition table after the restore, but I can live with this workaround.