Permissions problem with backup path on Ubuntu Server

I am new in UrBackup and ran into a permission problem for the server backup path. There are some topics for this problem down to 2016, but I don’t see any solution.
Here is my problem as described in the web interface:

The directory where UrBackup will save backups is inaccessible. Please fix that by modifying this folder in ‘Settings’ or by giving UrBackup rights to access this directory. (err_folder_not_found). Permission denied (code: 13)

Detailed error info:

Can access /
Can access /media
Cannot access /media/leo. Permission denied (code: 13)
Cannot access /media/leo/FS-LEO-04. Permission denied (code: 13)
Cannot access /media/leo/FS-LEO-04/urbackup. Permission denied (code: 13)

So I investigated the backup path and found some permission settings that prevented UrBackup to access the backup path/file. As far as I can see it’s ok now and restarted the service, but still the same problem.

The backup path to a USB drive is: /media/leo/FS-LEO-04/urbackup
Here is a summary of the permissions of the full path:

drwxr-xr-x 3 root root 4.0K Feb 2 08:43 media
drwxrwx—+ 4 leo urbackup 4.0K Feb 3 10:41 leo
drwxrwx— 7 leo urbackup 4.0K Feb 3 11:35 FS-LEO-04
drwxrwx— 2 urbackup urbackup 4.0K Feb 3 11:28 urbackup

Appreciate any help as I am excited to start using this excellent product.

Which user are you running the server under ?
/usr/local/bin/urbackupsrv run -u root

I am not sure I understand your question. I am not a linux specialist. I just ran the install script on ubuntu/mint21. Please let me know what command to run to answer your question.
This is what I get when I list the status of the service.

● urbackupsrv.service - LSB: Server for doing backups
Loaded: loaded (/etc/init.d/urbackupsrv; generated)
Active: active (running) since Sat 2023-02-04 09:05:17 PST; 16min ago
Docs: man:systemd-sysv-generator(8)
Process: 984 ExecStart=/etc/init.d/urbackupsrv start (code=exited, status=0>
Tasks: 18 (limit: 4560)
Memory: 19.9M
CPU: 328ms
CGroup: /system.slice/urbackupsrv.service
└─1068 /usr/bin/urbackupsrv run --config /etc/default/urbackupsrv >

Feb 04 09:05:15 dt02x systemd[1]: Starting LSB: Server for doing backups…
Feb 04 09:05:17 dt02x systemd[1]: Started LSB: Server for doing backups.

As far as I can see urbackupsrv is owner of the permission group urbackup, which I assigned in the path directories as permitted group and as owner of the directory urbackup in the path.

If you run “top” what USERNAME is urbackupsrv using ?

The user that is running urbackupsrv is “urbackup”.

Fortunately I found the cause of my “permission” problem in the Installation and Maintenance manual under section 8 as follows:

Backup storage path
The backup storage path is where all backup data is saved.
To function properly all of this
directories' content must lie on the same le system (otherwise hard links 
cannot be created). How much space is available on this le system for UrBackup 
determines partly how many backups can be made and when UrBackup starts 
deleting old backups. Default: "".

I mounted my backup USB drive under my /Backup partition and that is another filesystem.
After creating a mount point under / (root) and entering the new path under settings of UrBackup, the path was accepted and the error message disappeared.

Anyway thanks to all who who tried to understanding my problem and especially to [alecmascot].

1 Like