OS X 10.6.8 Client Installs but won't run

I just installed the latest Urbackup client on OS X 10.6.8
The client appears to install correctly but then nothing else happens.
I can’t launch the app from the Applications either.

The client is running in the background as it can be seen from the process viewer.
It also shows as connected in the server client list.
It does not show the icon for the gui.

Has anyone else had these issues?

What does it say if you try to run the GUI from the command line?

That’s difficult to answer as the process is running and when I try to stop it by force it keeps restarting before I can do it manually.
I also only have remote access…

Hmm the GUI restarts? The GUI part is urbackupclientgui

Not the gui but the background process. There is no gui.
The status is as follows;
Ellies-Mac:bin danieledisilvio$ ./urbackupclientctl status
“capability_bits”: 4193,
“finished_processes”: [],
“internet_connected”: true,
“internet_status”: “connected”,
“last_backup_time”: 0,
“running_processes”: [{
“action”: “FULL”,
“eta_ms”: 0,
“percent_done”: -1,
“process_id”: 1,
“server_status_id”: 2210,
“speed_bpms”: 0
“servers”: [{
“internet_connection”: true,
“time_since_last_lan_connection”: 4131611

Well, that is the problem right? The process showing the icon is urbackupclientgui. Is that one running?

Not that I can see.
It would have to be started via cli as the App will not launch from the Applications folder.
It does nothing at all when double clicked.

You can start it as root as user with:

sudo -u username “/Applications/UrBackup Client.app/Contents/MacOS/urbackupclientgui”

I get application has already started.

Ellies-Mac:MacOS danieledisilvio$ sudo ./urbackupclientgui
Application is already started

Still no gui and the client seems to run in the background from boot without the gui. It’s in the user account login items list as it should be.

Could it be that 10.6.8 is too old?

I have to stop for today it’s getting late at the remote users end… Time waits for no man…

You have to start it as the logged in user not root.

I tried that first but it still said it ‘Application is already started’

So does it run? (ps -Af | grep urbackupclientgui )

I’ll take a look tomorrow and report back.
Thanks, as always, for your prompt help.

You may have to restart the computer or logout/login in order for the GUI to show. It’s buried in a launchd directive so you should use launchd to start it.

I tried a restart. No change.
I haven’t had chance to contact the Mac owner yet.
Will try tomorrow.