Option to inhibit sleep during backup

I’ve got several windows 10 machines with urbackup installed. For sake of saving on power consumption, all of them are set to sleep if they don’t get any activity. For some of these machines they’ll only get used once or twice a day, and otherwise sleep. Because the machines sleep so aggressively, Urbackup can’t finish running backups. Even incrementals get interrupted half of the time.

If urbackup had a setting to inhibit sleep while a backup was running, that would make it more reliable for backups to finish.

Related to this, it’d also be wonderful if urbackup could schedule the machine to wake automatically at the next backup time slot for an incremental backup to run.

1 Like

Awesome idea! +1 if uroni is looking :slight_smile:

1 Like

I’m sure the devs know better than me but because I need my clients always on to receive updates and such I generally use this script to change their power plan.

Try {
    $HighPerf = powercfg -l | %{if($_.contains("High performance")) {$_.split()[3]}}
    $CurrPlan = $(powercfg -getactivescheme).split()[3]
    if ($CurrPlan -ne $HighPerf) {powercfg -setactive $HighPerf}
} Catch {
    Write-Warning -Message "Unable to set power plan to high performance"

If you could find a way to export the existing power plan in Windows then you could restore it after the backup is finished.

It already prevents sleep during backups. Must be something about the configuration etc.


Are you sure the devices are awake when the backup starts?

I haven’t been paying super close attention, but I’ve seen these machines go to sleep several times. Specifically some of the machines in my home.

Steps I’ve taken before:
Power on the machine from cold shutdown
Log in to account with admin rights
Locate tray icon for Urbackup
Right click -> Initiate full backup
Walk away
Come back an hour later, machine is sleeping
Look at Urbackup webgui, shows status of backup at half-done.

Is it able to inhibit sleep from, e.g. laptop lids being closed? Or is it only able to inhibit sleep from the inactivity timeout?

Note, I’m not saying that the machine in my example was a laptop, or that it went to sleep from the lid being shut. I do have laptops that are set to sleep on lid shut, but the machine I had in mind for my example was a desktop.

I’m also not doing anything exotic here. The best feature of Urbackup is that it’s an “Install the client, and you’re completely good to go” software. As far as I know, I haven’t changed any settings on any of the clients beyond basic windows settings accessible from the various Windows GUIs. So these should be as vanilla as they get. I certainly haven’t run any urbackup scripts on the client. Just installed and left it alone. Some settings on the urbackup server have been changed, such as backup directories and such but nothing out of the ordinary.

Windows applications cannot prevent the computer from sleeping if it is configured to sleep when the lid closes. It can only prevent the idle sleep.

1 Like