Only one new client doesn't come online


#1

Hi,

I added these days two more clients which has already 12 working clients.
The first one went well and the first backups are already done. The second was added (tried it twice) is running on the client machine, but on the server the status is “ok” and online shows no.

I checked also the firewall / port settings together with hosting provider to be sure that none are closed.
After re-installation I get only this warning in the client’s log file:

WARNING: Shutting down (Signal 15)

Where do I have to look further?
The client is installed on Ubuntu 18.04


#2

and what happened in client’s log if you turn on debugging at config file?
p.s.: for ex. at debian config located at /etc/default/urbackupclient


#3

Good idea :slight_smile:
Do I need to (re)start the client or just wait?


#4

yeah, restart is required


#5

I guess it’s not

# service urbackupclientbackend start


#6

service urbackupclientbackend restart
or
/etc/init.d/urbackupclientbackend restart

the last works for me at debian


#7

I needed to stop the client first to get some changes in my log file. Now I get this and it looks good to me.

2018-09-20 13:15:28: SQLite: recovered 24 frames from WAL file /usr/local/var/urbackup/backup_client.db-wal code: 283
2018-09-20 13:15:28: urbackupserver: Server started up successfully!
2018-09-20 13:15:28: FileSrv: Server started up successfully
2018-09-20 13:15:28: Started UrBackupClient Backend…
2018-09-20 13:15:29: Looking for old Sessions… 0 sessions
2018-09-20 13:15:30: Trying to connect to internet server “vps1.domein.nl” at port 55415
2018-09-20 13:15:30: Successfully connected.


#8

How high is your “Max recently active clients:” in the server settings?


#9

It’s 10.000 (never changed that value) Is it safe to raise that value and if yes how much?


#10

Well, you probably don’t have more than 10000 clients, so this is probably not the cause…


#11

Yes right, I added also another server afterwards and that one connected without any problems.
Right now I have ~15 clients for that backup server and only one has these problems. Same server config just a different datacenter/provider. I checked the firewall setting (10 times) and also the open ports on netwerk level.
It’s just the problem that this one client doesn’t connect on the backup server (status = ok and online = no)


#12

I remember me that the first time I installed the client I forgot to whitelist the IP address first. Looks like after I did the whitelist, this installation/configuration wasn’t finished. Today I removed the “old” non-working client and added the same host with the IP address and than it suddenly worked as with all other servers.


#13

I found the reason why this client never started a backup. It looks like there is a problem if you add a hostname a second time after you removed that one before. I give all my servers a name like vps1.domain.com and sometimes I remove an server and use the same name later for a new server.
If I do so it doesn’t work. If I remove that server (uninstall the client too) and add the same server with the IP address as hostname it works just like before.

Is there a way to solve that problem? I would like to keep using my hostnames instead of IP addresses.
Thanks