One client no longer sees second backup server

I have 2 urbackup servers, and several clients backing up to both. It’s been working fine for a year or so, but last week both backup server machines crashed, and after restart, one client cannot see the second backup server.

both servers are running 1.4.13
all clients were running 1.4.7

after restarting everything, one machine kept reporting no connection error-2 for both servers, even though I could ping the ip addresses from that machine.
I stopped and started the 1.4.7 client service, but no difference
I reinstalled the 1.4.7 client, but no difference.
Then I installed 1.4.11 client, and it suddenly found the first backup server listed in server_idents.txt and backed up successfully there.
It doesn’t see the second one (server_idents.txt is identical on all the clients, and I have checked this again after installing v1.4.11).
If I get the second backup server to initiate a client backup on this client, the attempt to backup aborts almost immediately with “constructing of filelist of ‘chloe’ failed: ERR”

I suspect it’s something simple that I’ve missed doing. I’m hoping wiser heads than mine can suggest what to look at next.


I guess at this point you have tried restarting the server which fails to backup the client, or kept the client offline for at least 5min such that it shows online = “No” on the web interface?

I tried all of that on saturday. Then when nothing happened after an hour, I used URBackup server to request a backup of the client. That ran successfully. But only that one. Subsequent attempts all fail with “constructing of filelist of ‘chloe’ failed: ERR”

should I try something like deleting failed backups from that server for that client?


Two days ago I ran the remove_unknown command on both backup servers. Since then, the troublesome client has backed up to both servers without error.

I am continuing to monitor this, but it looks as if the issue is fixed.