Not listening on Ports - OMV plugin


#1

It seems like I am having issues with the urbackup-server not wanting to listen on the set port of 55414 or 55415 for the web interface. My Docker transmission is fine. I run netstat -tap | grep 55414, and get a blank line in return. I’ve added an incoming rule for those ports. Still nothing. Its like the service is failing to listen on those ports. No number of restarting of the service brings it up. lsof -i :55415 also brings back a blank line. I love a puzzle, but this sure is a conundrum. Oh go easy on me too, its my first time posting here!


#2

Oh, also it seems that its not listening on the local host. Anyone know how this can be fixed?


#3

/etc/default/urbackupsrv Found this but didn’t see anything listed for localhost. I did see a broadcast on interface option, but it is set to default.


#4

Am I right that you cant access you web console from external or in your local network?


#5

Only trying to access it on my LAN. I even uninstalled the plugin and reinstalled it, disabled docker, and still no dice. Its like the service is not listening on the configured ports.


#6

Is the server network and local network in the same network? Maybe there is some problem with you firewall settings? Trying to access it with http://yourserverip:55414 ?


#7

Yeah it is in the local network. There is a link inside OWV service tab for the plugin. Plus the service isnt listing on that port. So no matter if you try to access it via host name or IP in the browser. I also have a thread going on the OMV fourms too.


#8

So I did a complete reinstall. Loaded up freshly downloaded omv, omv-extras, and the server-urbackup. Changed the listening web port to 55415. Still no dice. Any ideas? I would love to use this style of back up for my workstation because I wouldnt have to have an open share. Plus with the headache of Windows having issues with SMB 1 and other conflicting issues.


#9

Its as if it is failing to bind the service to that port. IDK. I’ll keep poking at it for at bit until I either toss it out the window, or figure out what is going on. Here is another idea: would there be an issue with my hardware? But then I wouldn’t be getting the webinterface for OMV right?

Edit:
Found a bunch of these in the OMV syslog after restarting the server-urbackup service.

Jan 26 00:05:52 openmediavault collectd[866]: rrdcached plugin: Failed to connect to RRDCacheD at unix:/var/run/rrdcached.sock: Unable to connect to rrdcached: No such file or directory (status=2)


#10

Ended up going with an installation of ubuntu server 18.04. With some firewall rules and other tweaks, I am now able to use the software and backup clients. Idk why the original setup didn’t work for me, but thanks for the help.