No option to mount vhdz backups

I set this up on my freenas 11 box. The backups go through just fine. However I cannot get an option to mount the image files (vhdz) on the web portal. I set the server-approves on the clients and restarted both the clients and the server. All of my clients are windows boxes at this point. Please help.

On a side note I am considering redeploying the server following this to use the ZFS copy on write, but I believe that would be unrelated to this issue.

Not wholly unrelated. On FreeBSD it only works with raw images and if you run urbackupsrv as root and not in a jail (maybe you get it to work in a jail… idk).

I do have it working in a jail.
And with the raw images, the new setup would be RAW with COW. But everything says is should work with vhdz. So I would still lvoe input on anyone that has ran into this, but will work on getting the ZFS working in a jail per this guide

To be clear, I know the cow needs the raw. I am asking simply about getting the mount image option working currently.

As far as I know you would be the first person who solved the problem with mounting on freebsd. I have tried it with warden and iocage jail. No luck. I now running urbackup in a freebsd vm and still have no luck with mounting the image files and I try it hard. After giving up I decided to not need this function :wink:

Same here. FreeNAS 11 with UrBackup in jail.

Can’t mount images, though I’ve seen it work on Windows server installs.

As I said, on FreeBSD only mounting raw images works. And I have only tested it as root and not in a jail.

I got this working with direct ZFS Access in a jail on FreeNas 11.2 in a jail using RAW with Copy on Write. It was running as root (for the jail). Still no mounting of hard drives. Do you have a comprehensive list of OS that do support image mounting, even the vhdz or such? I was going to move this to either a fedora server or windows server core box.