New server installed - Windows 10 client shows " Backing up System Reserved (SYSVOL) partition failed"


I have set up a new server today (running a jail on FreeNAS 11).
The setup was straight forward as usual and done several times before.

Furthermore I have “jailed” a ZFS dataset to the UrBackup jail to be able to use COW images.

The problem is that my Surface 4 (Windows 10 Pro) does not do any backups anymore - it worked with the old server before!
I have already completly uninstalled the UrBackup client on that machine and re-installed it again.

As soon as the image backup is started, I can see “Backing up System Reserved (SYSVOL) partition failed” in the log and also the urbackup.log in /var/log/ on the server.

Doing some tests with “sysvol_test.exe” on the client did not show any errors.

I have seen that there have been some discussions before and I already tried all of that fixes without success :frowning:

I have tried client version 2.1.16 (from website) and also 2.1.19-cbt (with my CBT license).
The server is running on version 2.1.19.

Perhaps anyone has had the same problem or an idea how to debug this and perhaps even solve the problem?

Kind regards,
Daniel / Wulffi

Hi Uroni,

do you have any idea on this issue?
Currently all my clients fail with the same error message and even a complete reinstall did not solve the issue.

If you can specify which logs you would need, I will of cause provide them as soon as possible.

Thank you!

Kind regards,

Looking at the log file I am guessing it is failing to create ZFS snapshots for some reason. Or it cannot write to the created snapshot afterwards…

Can you create snapshots with urbackup_snapshot_helper 1 create clientname test ?

Yes, that worked without any problem!

I can see that a new dataset has been created using “zfs list”.


I did some further testing today.
As soon as choose the standard VHD image or compressed image everything works fine.

Therefore it must have something to do with the ZFS setup in a FreeNAS jail as it has been working on a Debian workstation before…

Do you have an idea, uroni?

Just a short summary of what I have already done and tested:

  • Created a jail on FreeNas11 called “UrBackup”
  • Created a zfs dataset called “UrBackupImages”
    –> zfs set jailed=on Pool/UrBackupImages
    –> zfs jail UrBackup Pool/UrBackupImages

In the jail I can use e.g. “zfs list” and see the jailed ZFS dataset, I am also able to create and destroy subdatasets. Running “urbackup_snapshot_helper test” is successful and also the urbackup.log does not show any problem until now.

As soon as the client backup job starts, a new dataset is created with the client name and an additional subdataset with the date, etc.

So from that perspective everything looks quite fine and as expected.


I have done several tests during the past days and did not find the problem until now.
Today I have seen an error message for the first time - in all other log no error appeared:

2017-07-29 07:38:51: Starting scheduled full image backup of volume “C:”…
2017-07-29 07:38:51: Starting scheduled full image backup of volume “SYSVOL”…
cannot mount ‘Pool/UrBackupImages/Daniel-Surface/170729-0738_Image_SYSVOL’: File name too long filesystem successfully created, but not mounted

Is there any way to prevent such long file names?
Of cause I can change “UrBackupImages”, but e.g. the client name is fixed in the network.

I have checked the above-mentioned path and the length is 59 characters.

According to the information below, there should only be problems with path length more than 87 characters.

Kind regards,

Well, where is it mounted?

I don’t think the length is excessive. Rename your pool to “a” or something to save on length ;). It also seems only FreeBSD has such a limitation.

I have changed the pool name to “UrI” for images and “UrF” for files and everything is working just fine!
Thank you for your help! :slight_smile:

If it should be of interest, I can write up a short summary of how to set up UrBackup in a FreeNAS jail including access to a ZFS dataset.

The mount point within the jail was not the problem - but the dataset is also mounted outside the jail on the basic system and this path is quite long /mnt/Pool/Jails/Urbackup/mnt/Pool/UrBackupImages (mnt/[ZFS_dataset]/Jails/[Jail_name]/mnt/[ZFS_dataset_within_jail]/).

Kind regards,

I would guess there is some interest. I’m running it directly on the host system without jail, but that isn’t easy to setup either (and hackish). I guess image mounting does not work?

Either the wiki or a wiki post here, would be good. I can link it from the home page.

That is right - I have just tested it on my server and even if I have compiled the server with VHD support, there is no function as soon as I click on the link to mount it in the web interface.

I will write a short summary within the next days as the mounting of a ZFS dataset in a jail took quite some time as I could not find any updated documentation.

Kind regards,

I would suggest to try “Long Path Tool” program.