New Installation on Windows Server 2016 Essentials + Windows 10 Clients is very slow and keeps hanging sometimes

Hi there,

I was looking for a new backup solution and found UrBackup on the Internet, so I’ve installed the server app on my Windows 2016 Server + client app (latest available versions Client 2.5.25 and Server 2.5.32). Backup storage is a SMB destination located on a ZyxelNAS. I’ve also added several other clients, all running with Windows 10 (with latest Microsoft updates). All on LAN, no internet clients. I do only file-backups, no image backups needed.

First, why are the speeds are so slow? The NAS is connected via Gbit-LAN, I’ve tested xfer speed and I get ~60MB/s. But not so with Urbackup…

Second, some backups keep just hanging, for example:


19.10.23 15:01  	INFO  	IST-Server2: Loading file list...
19.10.23 15:01  	DEBUG  	IST-Server2 Starting incremental backup...
19.10.23 15:01  	INFO  	IST-Server2: Calculating file tree differences...
19.10.23 15:01  	INFO  	IST-Server2: Indexing file entries from last backup...
19.10.23 15:01  	INFO  	IST-Server2: Calculating tree difference size...
19.10.23 15:01  	INFO  	IST-Server2: Linking unchanged and loading new files...
19.10.23 15:01  	DEBUG  	Loading file "kundendienstelog.txt"
19.10.23 15:01  	DEBUG  	GT: Loaded file "kundendienstelog.txt"
19.10.23 15:01  	DEBUG  	PT: Hashing file "kundendienstelog.txt"
19.10.23 15:01  	DEBUG  	HT: Copying file: "\\\Sicherung\UrBackup\IST-Server2\231019-1501\IOS2000\kundendienstelog.txt" (id=197)
19.10.23 15:01  	DEBUG  	HT: Renaming file to "\\\Sicherung\UrBackup\IST-Server2\231019-1501\IOS2000\kundendienstelog.txt"
19.10.23 11:36  	INFO  	al-pc: Calculating tree difference size...
19.10.23 11:36  	INFO  	al-pc: Linking unchanged and loading new files...

What could be the reason that nothing happens there? I’ve also tried to abort the tasks via webUI… but after more than 1 hour nothing happens…

Big thanks for the help!

If this was happening to me, I think I would first try to set the storage destination to something other than the NAS at first. Not saying that’s the problem, but that’s what i would do as a test. I would also look at the live logs and see if you see “getting file list (async)” is showing as the current activity. That process can take some time and it appears as if it’s hanging, but it’s not.

Sorry this is not as helpful as you may have wanted. I’m sure someone else will chime in.

You’re right. I’ve changed the backup path to local drive and it is a lot faster, but why? The NAS is not that slow. I will continue testing … any Ideas?

What interface is between the NAS and the server, Ethernet, USB 3, 3.1?

And more importantly, what protocol is it using?

The Zyxel NAS520 is connected via GBit-Ethernet with SMB shares.

If you connect to that NAS from another computer and try to just transfer files back and forth, what speeds are you getting? It looks like that model has Dual NICs. Are you using both ports? Just curious.

I’m not sure how new the NAS is and if you’ve already populated it with hordes of data, but if you haven’t, I might “scrub” or scan both disks in their independently to check for drive health. Maybe one drive is pulling down on the other and causing the speeds to be horrendous. Just thinking out loud.

I’m just using one NIC.

I get good speeds, on up- and download. Around 30 MB/s.

Both Discs are good. No Problems. Only few percent space in use.

Someone else should chime in here. I prefer DAS storage systems vs a protocol like SMB. Can’t say that is the root of the problem, but whatever it is, I think the problem would be solved by either direct attaching the devices or modifying the configuration on the NAS, perhaps there are some modifiable adjustments for caching or other such settings either in the NIC settings, etc. that might be the cause of this unexplainable slowdown. Don’t have a great answer for you on this.

This NAS doesnt have anywhere near the through put your need, the board only supports SATA 2 (3Gb/s) its super old technology with DDR3 1Gb of RAM and a CPU ive never heard of. I would think it will bog down after about 2-5Gb written.

I was testing this directly on a QNAP older generation NAS (SATA3 connection, with an Intel CPU and 8Gb of RAM) with URBACKUP run directly ON the NAS (not through a virtual machine) and even a direct connection to the store would bog on backups over 300Gb, this nas had WD RED NAS drives and a SATA 3 backplane.

I wasnt aware UrBackup would work over SMB due to the upper / lower case file issue, i thought it would only work with something like NFS through a network share.

Thank you for the answer.

Well, can you recommend a good NAS which fits my needs? It should have Raid 1 with 1-2TB space for backups.

And you said SMB is not recommended? Do you prefer NFS for Windows PCs?

Well the irony here is if you purchase a QNAP Intel or QNAP AMD NAS you can run UrBackup actually ON the NAS as a server (no PC / Linux PC required). So that would be your best option, however you need a lot of RAM (at least 4Gb). It also depends how many and what type of PCs you want to back up…

Please review the below about the QNAP install.

I have 1 x Windows Server 2016 and 5 x Windows 10 Clients to backup. UrBackup is running on the Windows Server atm.

What do you plan to backup from all these terminals? (how much data is on the disks) Planning just files or images as well?

Files only from most of the clients. Just the Server uses image backup, which has ~ 60 GB. The Desktop PCs + Server file backup is ~ 250 GB all together.

Entry level would be QNAP TS-262-4G, this should allow you to load UrBackup directly on to the NAS so you dont need a server…

Be aware ive not tested this, i would suggest getting one used first to decrease the outlay of money, send me a DM for any parts you might find, we can talk over that about specs to keep this forum clean.