New Install on Freenas 11 Jail, No access to Web Interface


#1

When trying to connect to http:\192.168.1.182 I get Connection refused message.
Nmap shows connection to ipaddress.
Nmap scan report for UrBackup.connect (192.168.1.182)
Host is up (0.0014s latency).

I followed the instructions at
http://www.urbackup.org/freenasserverinstall.html

First Time I have tried this software, installed straight away, but I can not get to the webadmin.

Any Ideas ??

Peter


#2

Try http:\\192.168.1.182:55414 as the web interface is on a non-standard port for http you have to specify it. without the :55414 you’ll be trying to connect to a closed port “connection refused” is the expected result.

Failing that, look into possible interference by firewalls.


#3

I forgot to mention that I use port 55414.
http://http://192.168.1.182:55414


#4

There is no Firewall on Freenas, it is not exposed to the Internet.


#5

It looks like you need to start the service with
( /usr/local/bin/urbackupsrv run -d -g 104857600 -u root)

From

I have not been able to try this as I deleted the jail and tried again but now I get errors in the make command.


#6

That works but only until the jail is restarted. Need to find a way to get it automated on start up.


#7

Here is the script I’m using to autostart.

Use nano to create the file:
nano -wc /etc/rc.d/urbackupsrv

Add this to the file:
#!/bin/sh
. /etc/rc.subr
name=urbackupsrv
rcvar=urbackupsrv_enable
command="/usr/local/bin/${name}"
command_args=“run -d -g 104857600 -u root”
start_precmd=“cd /usr/local/var”
load_rc_config $name
run_rc_command “$1”

Run this:
chmod +x /etc/rc.d/urbackupsrv

Run this:
echo ‘urbackupsrv_enable=“YES”’ >> /etc/rc.conf