New Install. All Clients show Connected but Server shows clients are down

Hi all, I have a client 2.4.11 (Windows) installed on my Win10 pc and I spun up an AWS EC2 VM to backup some files. I have everything configured properly to connect over the internet and my client shows connected but the online status on the server is always “No”.

I opened up ports 55413-55415 TCP inbound and 35623 outbound (UDP) from the AWS server side but no luck. No windows firewall or antivirus on both server or client

Check this items:

  1. After you enabled internet mode, server was restarted.
  2. You now should create clients in Web UI on server (I recommend), or replace identity files manually.
  3. You need only single port to be forwarded on Security appliance for Internet clients 55414. Other ports is for LAN.
  4. Ensure other settings is correctly configured.

Thanks @artyomtsybulkin

  • I restarted after enabling internet mode several times but no luck
  • I’m not sure what you mean by replacing identity files. I tried creating on server and client. Server side by clicking on add and entering client hostname on NAT field. I also downloaded client installer from server web gui, uninstalled client app, re-installed, added client on client side and saw that the client appeared on the servers GUI but still offline
  • I modified inbound rules to allow for only 55414 but no change.
    -I’m pretty sure settings are configured correctly. Proven by me installing client using servers installer and the client showing up on the server but no online.

Good! If you have no idea about identity then you issue problem related to it.

Read Admin guide:

4.3 Client security

UrBackup Client only answers commands if the server or the interface process supply it with credentials. The server credential is saved in ’/var/ lib/ urbackup/ server_ident.key’. If it does not exist the server will randomly generate it the first time it runs. The server identity is also confirmed by private/public key authentication. If not present the server will generate a private and public ECDSA key in ’server_ident_ecdsa409k1.priv’ and ’server_ident_ecdsa409k1.pub’.

Just create client using Web UI install it and it must works.

Hi!

I have same problem.
Installer has downloaded form web gui, but same.
Client connected to internet server OK.
In the web gui, online: NO
The mentioned ports are opened, i cant start backup from the webgui.
"Failed to start"

Have you any idea?

Thanks
Feko

Ok. Do you use only dedicated internet server or you have LAN urBackup server and Internet server somewhere else? Situation you both describing is related identity problem (I think), but may be something else like Security Appliance filtering traffic (you can check logs on it). If you see that client connected in Web UI then something wrong with identity. Also check how VSS working on client system (Do you trying to backup Windows OS?). Check urBackup logs on server and clients (May be fs permissions problem check that account running server is able to write and read on disk).

Server identity files (name starting server_identt…) on Linux located: /var/urbackup/server_ident*

Hi!

The server running on TrueNAS core with fixed/different IP address.

Feko

Worked!!!

Solution: I ran Wireshark and wasn’t seeing the TCP 3-way handshake so I changed internet port setting to 55555 from 55414 on server and client and restarted urbackup services on server and client.

You will also have to modify any port forwarding rules to accommodate for the port number change.

Thanks again!

1 Like