New Bug? Client authentication failure for "computer-name" from xx.xx.xx.xx

Linux server: v2.5.27 upgraded, from v2.5.26, from v2.5.25, from v2.4.15
Windows clients: v2.5.21 upgraded from v2.5.19, from v2.4.11

I’ve noticed lot’s (most) of my clients are forgetting the “client name” we original setup and reverting to the actual computer’s name instead. This is causing them to become disconnected from the server (almost all are internet clients, not local). I’ve had a few change the “Computer name:” from the client settings back to the original client name we gave them, but some clients still revert back to a blank and the client starts using the actual computer’s name instead of the client name again (thus disconnects from the server and shows errors like below).

In /var/log/auth.log I see lines like this:
Client authentication failure for “computer-name-A” from xx.xx.xx.xx
Client authentication failure for “computer-name-B” from xx.xx.xx.xx
Client authentication failure for “computer-name-C” from xx.xx.xx.xx
Client authentication failure for “computer-name-D” from xx.xx.xx.xx

I’ve been using UrBackup for several years, and usually just just the user’s firstname.lastname when adding a new backup via the “Add new client” setup. And downloading the windows exe file.

I guess my questions are these:

  1. Has anyone else noticed this issue?
  2. Should I only use the actual computer name for the backup clients going forward?
  3. Any advice on how to I fix this for 100’s of clients without manually touching each one?


Just did a small upgrade test. Cannot reproduce the problem.

Thanks for trying uroni,

I also notice that some of my clients are showing this error in the Online column on the “Status” tab:
Yes (Error during server authentication)

I’ve checked my “server_ident_ecdsa4091k." files and "server_ident.
and they haven’t changed since 2016 when I installed the server, so I’m not sure what is causing my issues.

Edit, more info:
Also, if I log onto the client and change the “Computer name:” in settings to match my configured client name, it works right away. I’m just not sure what causes the clients to start “forgetting” the client name.

Any ideas?

Thanks again for the awesome software and support!


I’ve just logged into my server and changed the “client name” under the clients tab in settings for all 301 users from the blank entry to match the originally configured client name we gave them. This changed the padlock symbol from “using setting from group” to a house symbol “using setting configured here”

Not sure if that is the appropriate step to take, but I’m pretty desperate for a fix at this point. I’ll report back if this makes any difference.