Mounting a backup image via the web interface

I thought I should check that I could mount a backup image just to make sure it still worked. It used to work a few months ago.

Several hours later the web interface is still spinning its “I think I may be somewhere here but try looking later” wheel. it has been about 6 hours so far and I am about to reboot the server to try to recover.

I have a Debian 10 server and I happened to select a disk image at random for a windows 10 workstation. I believe the disk is about 1Tb .

/var/log/urbackup-fuse.log contains:

2020-07-13 11:25:42: Mounting VHD via fuse...
2020-07-13 11:25:42: VHD-Parent: "/srv/urbackup/amber/200407-2001_Image_D/Image_D_200407-2001.vhdz"
2020-07-13 11:25:42: Volume offset is 524288 bytes. Configure via --offset

The most recent urbackup.log entry is from 2020-07-13 11:01:30 and the current time is 2020-07-13 18:36;15 so I think the server is not doing its job, many backups should have occurred in that interval.

Software versions:

  • Debian GNU/Linux 10 (buster)
  • Linux curlew 4.19.0-9-amd64 #1 SMP Debian 4.19.118-2 (2020-04-29) x86_64 GNU/Linux
  • UrBackup Server v2.4.12.0

The client was not involved but the image was for a client with software versions:

  • Microsoft Windows 10 Pro (build 19041), 64-bit
  • urbackup client 2.4.10

Did I need to just keep waiting or is there a fault?

I tried looking at the state of the system

root@curlew:~# mount
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/vde4 on /mnt/p4 type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
/dev/vde2 on /mnt/p2 type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
/dev/fuse on /srv/urbackup/amber/200706-2039_Image_D/device0 type fuse (rw,nosuid,nodev,relatime,user_id=115,group_id=125)
/dev/fuse on /srv/urbackup/amber/200706-2039_Image_D/contents0 type fuse (rw,nosuid,nodev,relatime,user_id=115,group_id=125)

root@curlew:~# ll /srv/urbackup/amber/200706-2039_Image_D
ls: cannot access '/srv/urbackup/amber/200706-2039_Image_D/device0': Permission denied
ls: cannot access '/srv/urbackup/amber/200706-2039_Image_D/contents0': Permission denied
total 265220
d????????? ? ?        ?                ?            ? contents0
d????????? ? ?        ?                ?            ? device0
-rwxr-x--- 1 urbackup urbackup  88423338 Jul  6 20:49 Image_D_200706-2039.vhdz
-rwxr-x--- 1 urbackup urbackup  61047308 Jul  6 20:40 Image_D_200706-2039.vhdz.cbitmap
-rwxr-x--- 1 urbackup urbackup 122094560 Jul  6 20:49 Image_D_200706-2039.vhdz.hash
-rwxr-x--- 1 urbackup urbackup       565 Jul  6 20:39 Image_D_200706-2039.vhdz.mbr
-rwxr-x--- 1 urbackup urbackup         0 Jul  6 20:49 Image_D_200706-2039.vhdz.sync

root@curlew:~# pstree
        │         └─2*[apache2───26*[{apache2}]]
        │         ├─lightdm─┬─lightdm-gtk-gre───6*[{lightdm-gtk-gre}]
        │         │         └─2*[{lightdm}]
        │         ├─lightdm
        │         └─2*[{lightdm}]
        ├─mosh-server───bash───tmux: client
        │      ├─lpqd
        │      ├─5*[smbd]
        │      └─smbd-notifyd
        │           └─10*[{syncthing}]
        │         ├─at-spi-bus-laun─┬─dbus-daemon
        │         │                 └─3*[{at-spi-bus-laun}]
        │         ├─dbus-daemon
        │         ├─dconf-service───2*[{dconf-service}]
        │         ├─gpg-agent
        │         ├─gvfs-udisks2-vo───2*[{gvfs-udisks2-vo}]
        │         ├─gvfsd─┬─gvfsd-trash───2*[{gvfsd-trash}]
        │         │       └─2*[{gvfsd}]
        │         ├─gvfsd-metadata───2*[{gvfsd-metadata}]
        │         └─xfconfd
        │         ├─at-spi-bus-laun─┬─dbus-daemon
        │         │                 └─3*[{at-spi-bus-laun}]
        │         ├─at-spi2-registr───2*[{at-spi2-registr}]
        │         ├─dbus-daemon
        │         └─gvfsd───2*[{gvfsd}]
        ├─tmux: server─┬─bash───pstree
        │              └─bash───less

I umounted /mnt/p2 and /mnt/p4, did a guestunmount /srv/urbackup/amber/200706-2039_Image_D/contents0, stopped urbackupsrv and rebooted. The server is now responding.

How do I mount a disk if I need to?