Make webinterface accessible via SSL


#1

I have followed instructions from admin manual and googled from every where, and i still can’t get it to work.
I have installed following setup from http://blog.urbackup.org/87/backup-server-for-the-raspberry-pi for pi and used the latest build for it.

Is there anyone who can help me with this ?


#2
for raspberry pi and debian:

sudo su
apt-get install nginx

openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/ssl/private/bu01.key -out /etc/ssl/certs/bu01.crt

openssl dhparam -out /etc/ssl/certs/dhparam.pem 2048

nano /etc/nginx/snippets/self-signed.conf
#
ssl_certificate /etc/ssl/certs/bu01.crt;
ssl_certificate_key /etc/ssl/private/bu01.key;
#

nano /etc/nginx/snippets/ssl-params.conf
#
# from https://cipherli.st/
# and https://raymii.org/s/tutorials/Strong_SSL_Security_On_nginx.html

ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_prefer_server_ciphers on;
ssl_ciphers "EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH";
ssl_ecdh_curve secp384r1;
ssl_session_cache shared:SSL:10m;
ssl_session_tickets off;
ssl_stapling on;
ssl_stapling_verify on;
resolver 8.8.8.8 8.8.4.4 valid=300s;
resolver_timeout 5s;
# Disable preloading HSTS for now.  You can use the commented out header line that includes
# the "preload" directive if you understand the implications.
#add_header Strict-Transport-Security "max-age=63072000; includeSubdomains; preload";
#add_header Strict-Transport-Security "max-age=63072000; includeSubdomains";
add_header X-Frame-Options DENY;
add_header X-Content-Type-Options nosniff;

ssl_dhparam /etc/ssl/certs/dhparam.pem;
#

nano /etc/nginx/sites-enabled/bu01
#
server {
listen 443;
server_name bu01.domain.com;

ssl on;
ssl_certificate /etc/ssl/certs/bu01.crt;
ssl_certificate_key /etc/ssl/private/bu01.key;
root /var/www/urbackup;
index index.htm;

location /x {
   include fastcgi_params;
   fastcgi_pass 127.0.0.1:55413;
}
}
#

ln -s /usr/share/urbackup/www /var/www/urbackup

systemctl reload nginx

and you are good to go..