Mail Server config not working

I am evaluating Urbackup for my backup system and so far I really like it!

However, one feature that I am particularly interested but seem unable to get working is the mail notification feature.

For settings I’ve tried:
(excuse the spaces where dots should be, apparently the new user filter doesn’t want to let me post more than 2 new links)

mail server: smtp gmail com
port: 465
username: myemail at gmail com
mail server password: an-app-specific-password
sender email: myemail at gmail com
send mail only with ssl/tls: checked
check cert: I’ve tried both checked and unchecked

I get the following error:
**Sending test mail failed. Error:** Failure when receiving data from the peer(ec=56), response reading failed

However, if I use curl on the host like so it works fine:
curl --ssl-reqd --url 'smtps://smtp.gmail.com:465' --mail-from 'myemail+backups@gmail com' --user 'myemail@gmail com:an-app-specific-password' --mail-rcpt 'sometestemail@gmail com' --upload-file somefile

Try TLS/STARTTLS port, which is 587 and both send and check TLS options ticked.

Unfortunately if I use those options I get

Sending test mail failed. Error: Failed sending data to the peer(ec=55), RCPT failed: 553

When testing this setup with curl I needed to switch from smtps:// to smtp:// for the email to be sent, but I did pass --ssl-reqd, so I presume that the email was actually transmitted with TLS encryption?