Mail flood when no space left

Hello

Maybe this is corrected in beta. But “no recent backup” and “out of space” is sligtly different error.
I am just reporting in case this case can also be corrected.

This morning we woke up to few 10 000 mails, i believe it was one mail per failled file.
We can t specify a quota by % because the storage is an EFS and it has basically unlimited space (and btw it s horribly slow for urbackup usage patern).
The issue come because of an error in a script, we used local storage instead efs.

So, various ideas/paths for improving this :
To throttle to max one per day/hour when no space left
To consolidate the error to one per backup instead of one per file (i belive it was one per file, maybe urbackup was caught in a loop)
Be able to specify a percentage and/or a fixed size (like : 90% OR 1T)
Eventually send a mail once when reaching 80%,90%, 95%, then rate limit mail sending when 100% at once per day/hour.

Could having a hardset quota, such as 50G, be a fix for you?
https://www.urbackup.org/administration_manual.html#x1-560008.1.14

This s already the case
That s why i have this problem, the quota is currently set at 1.5T
trying to clean the 2T backup
The issue is that whenusing the wrong fs, it started backuing up data to a 30GB fs and when out of space.

Thtas why one of the idea to avoid this was to be able to set and OR in the quota definition