MacOS Client issues: log file location and whole drive backup


#1

Hello there,

I have a urbackup server (v2.2.10) installed on a Raspi 3B+ running Ubuntu Mate and I’m trying a client (v2.2.6) over LAN running MacOS 10.13.4 (High Sierra); I hope you could please help me with the client side of this setup.

After setting it up and ensuring the server was up and running (at least could access it remotely via web GUI) I have failed to run the first full backup of the main hard drive on a slightly old mackbook pro. After the first error I installed the client directly from the server using the “Download client for MacOSX” button.

So, knowing it was not a setup issue and after I was still having no luck with the backup, first I tried locating the log file for the client as stated in the pinned message in the forum but no luck. So, at least, I managed to find the server log’s output via web.

So… first question, please… where is the client’s log file located in MacOS? There’s not a /var/log/urbackupclient.log and cannot find how to activate it in the client nor a urbackupclient under the /etc folder

Afterwards I realized that the server file logged “Constructing of filelist of [clientname] failed: ERR”

Tried to see if anyone else was having similar problems in the forum with not a lot of luck and finally, I tried another folder, this case my user’s home folder in mac and finally got it running at least with one folder.

So, the second question would be how to backup the whole hard drive (path: “/”) in the client for macOS? Could this be a permissions issue? My user has administration privileges so I don’t think this should be an issue… but still seems I’m not able to make it work

And this is it. I am really liking urbackup so I hope to be able to make it work.
Thanks a lot in advance for everything.


#2

It’s at /Library/Logs/urbackup_client_backend.log.


#3

OK, found it… will give it a look to find when it was not working… thanks!


#4

OK, let’s see if now I can provide some extra info (thanks again!): I have been checking the logs… checking agains the timestamp of the error logged by the server, the errors block on the client’s log should be as follows:

2018-06-03 21:10:37: ClientService cmd: #IcKayuSIrJGFdDTRubBXw#3START FULL BACKUP group=0&running_jobs=1&sha=528&with_permissions=1&with_scripts=1&with_orig_path=1&with_sequence=1&with_proper_symlinks=1&status_id=4&async=1#token=A4yHw6q9XxomZmsVX4P1
2018-06-03 21:10:37: ClientService cmd: #IcKayuSIrJGFdDTRubBXw#GET VSSLOG
2018-06-03 21:10:37: rc=0 hasError=true state=0
2018-06-03 21:10:37: rc=0 hasError=true state=0
2018-06-03 21:10:38: Client timeout in ClientConnector::Run
2018-06-03 21:10:40: ClientService cmd: #IcKayuSIrJGFdDTRubBXw#1CHANNEL capa=0&token=A4yHw6q9XxomZmsVX4P1&restore_version=1&virtual_client=
2018-06-03 21:10:47: Client timeout in ClientConnector::Run
2018-06-03 21:10:48: ClientService cmd: #IcKayuSIrJGFdDTRubBXw#2LOGDATA 1528053047 0-1528053036-Starting scheduled full file backup…
2-1528053037-Constructing of filelist of “KRAKOW.local” failed: ERR
2-1528053047-Backup had an early error. Deleting partial backup.

Before these lines there are some recurring errors logged as:

2018-06-03 21:10:17: ClientService cmd: #IcKayuSIrJGFdDTRubBXw#1CHANNEL capa=0&token=A4yHw6q9XxomZmsVX4P1&restore_version=1&virtual_client=
2018-06-03 21:10:21: ClientService cmd: STATUS#pw=nYvuTqlh5GTLCcwkOLv8fJp2wbV9m5
2018-06-03 21:10:27: Client timeout in ClientConnector::Run
2018-06-03 21:10:28: ClientService cmd: #IcKayuSIrJGFdDTRubBXw#1CHANNEL capa=0&token=A4yHw6q9XxomZmsVX4P1&restore_version=1&virtual_client=
2018-06-03 21:10:37: ClientService cmd: #IcKayuSIrJGFdDTRubBXw#2PING RUNNING pc_done=&status_id=4&speed_bpms=0&total_bytes=-1&done_bytes=0&paused_fb=1#token=A4yHw6q9XxomZmsVX4P1

And even before these, there are two recurring patterns (where I guess the problem lies and when the backup was not running):

018-06-03 20:56:52: ClientService cmd: #IcKayuSIrJGFdDTRubBXw#1CHANNEL capa=0&token=A4yHw6q9XxomZmsVX4P1&restore_version=1&virtual_client=
2018-06-03 20:57:02: Client timeout in ClientConnector::Run

and

2018-06-03 20:56:47: ClientService cmd: STATUS DETAIL#pw=nYvuTqlh5GTLCcwkOLv8fJp2wbV9m5

These last two are repeated quite a lot along the whole log… I somehow see a kind of recurring pattern on those error as I see the same commands over and over again… I’d much appreciate if anyone has any ideas. Thanks!