MacOS client 2022

Hi @Moisie

I’ve tried downgrading but it looks like its caused an issue.

I see this in the client logs
2022-06-07 13:19:09: SQLite: recovered 4613 frames from WAL file /Library/Application Support/UrBackup Client/var/urbackup/backup_client.db-wal code: 283

I’ve also attached a pic of what the menu from the icon looks like now.

Clicking access backup errors saying ‘cannot get server url’
Clicking status just says that there was an error and nothing can be backed up
image

hmmm actually by moving

backup_client.db backup_client.db-shm backup_client.db-wal

out of /Library/Application Support/UrBackup Client/var/urbackup the client was able to connect and has immediately resumed a backup. Hopefully it runs OK

Hi @absolution

Thanks for the feedback.

Yes - that’s normal. The SQLite database often doesn’t get cleanly closed, so you’ll see these messages. The same thing happens on the server.

I don’t yet know what determines this condition, but in my experience either waiting, or restarting the client process seems to kick it into life.

Ah good - please keep us posted! :crossed_fingers:

Unfortunately the problem has come back. The first backup started successfully (and had to be resumed a couple of times due to my Mac switching off) but new backup attempts since the first completed have failed with the usual error.

I’ve confirmed that I am indeed using client version 2.4.12 now.

Hi

Thanks for the update - but I’m out of ideas for the moment - sorry…

@absolution Maybe think about what might be different with this Mac. E.g. some firewall/security/anti-virus software is installed?

On Windows I’d say record a sysmon trace and maybe send that. On macOS the equivalent would be tracing it with dtruss perhaps. But that’s hard to use because of security reasons, so…

Thanks @uroni

This might not be Mac-related. The backup of the server itself (OS is ubuntu-server) is now struggling to backup, showing the same error.

So this could actually be related to the server itself…
The urbackup-server is just the official docker image though, so should be fairly static. I guess I could try removing it and refetching the container…

Maybe not…

My server backup did that one time 6 days ago and has been fine since. The Mac however is continuing to have the same issue.

To the best of my knowledge there’s no antivirus or firewall software installed on this Mac. The backups were completely fine until I upgraded to the latest OS. Is there anything apple might enable when upgrading to Monterey?

Alright, it looks like another client (a Windows PC client) just had the same error, so now a Windows PC, the linux server and a Mac client have had the same issue. The issue is definitely most common on the Mac client but I think there’s enough evidence that this is now related to the network or server.

Thanks for the help everyone.

Working well here thanks. Monterey 12.4 M1 mini. Looking forward to Apple Silicon native support, otherwise perfect so far! urbackup is exactly what I’ve been waiting for, Server is on a QNAP 451+

Al

I’m still unable to get this working on my Mac. I’ve been trying since the MacOS client was relaunched in 2021. Current issues continue to be

SQLite: recovered 4613 frames from WAL file /Library/Application Support/UrBackup Client/var/urbackup/backup_client.db-wal code: 283

I’ve tried uninstalling, deleting all etc, var files leftover and then reinstalling.

New issue, on installation I’m prompted that Urbackup Client doesn’t have full disk access. Full disk access is granted and the only way to get rid of the prompt is to restart the computer.

Hello @mafiaboy01

Sorry to hear about the issues you’re having. Could you please fill in some details about what you’re attempting to do, and what happens when you do so?

This is a normal message, and doesn’t indicate an error. It’s how the client re-opens its database on startup.

Yes - I know about that, but haven’t yet had chance to fix it - sorry. As you say, restarting the computer appears to bypass the issue.