MacOS client 2021

I am again getting errors that indicate the UrBackup client does not really have full disk access. However; I have told it to protect /Applications and two accounts in /Users, but it is getting upset about “Error while listing files in folder “/System/Volumes/Data/private/var/db/ConfigurationProfiles”. User may not have permissions to access this folder. Errno is 0”

I have confirmed that UrBackupClient still has Full Disk Access.

I am confused about why UrBackupClient is down that path to begin with. I can’t see any reason for it in the other messages that came out (about symlinks going off to places and needing to be verified).

What information can I provide to help with this?

~ Frank

Hi Frank:

Thanks for the feedback. The error you’re seeing is different from the ‘Full Disk Access’ Privacy permission, and is an area I’m working on at the moment - better removal of unreadable (or unbackupable, or unrestorable) system files - so in due course, this error will be handled better.

As to why the client is going down this path: I suspect you may have an alias to Macintosh HD somewhere inside /Applications or your two user accounts, which will lead the client here. The client will then be looking inside the folder to see what files it has, and whether they should be included in the backup - at which point the OS doesn’t give it permission.

Assuming you can’t easily find the alias to Macintosh HD in those places, you might want to try adding /System to the list of excluded folders, in the hope that the client will be prevented from delving too deep inside there; TBH I don’t know if this will work or not - but it’s easy to try!


First off, THANKS!

What I wound up doing was adding */private/var/* to the “Exclude from backup” list. I found that it wandered down the /private tree after I had excluded the /System/Volumes/Data/private/var/* tree.

I’m more than happy to be a test subject when you are ready.

~ Frank

(edited because asterisk-string-asterisk becomes italicized)

1 Like

Thanks Frank - glad you got it working!

Happy to see MacOS client back in the works, it was my #1 reason for not considering UrBackup before. Now that it is supporting Linux/Mac/Windows it is much better.

It does however seem to take a long time to index files. (approx 40Gb backup directory on a 1.5TB drive) Maybe in the future, there could be a way to process changed files only, This might be different depending on the FS being used.

Either way +1 for bringing it back.

I’ve been having an issue with the client I believe since upgrading to Monterey. It seems like it is trying to create a snapshot as part of the backup. I’ve removed and reinstalled the client multiple times and get errors like this
0-1638293647-Backing up “Eric” without snapshot.
0-1638293647-Indexing of “Eric” done. 449 filesystem lookups 0 db lookups and 0 db updates
0-1638293647-Eric_MBP: Loading file list…
0-1638293647-Eric_MBP: Calculating file tree differences…
0-1638293648-Eric_MBP: Calculating tree difference size…
0-1638293648-Eric_MBP: Linking unchanged and loading new files…
0-1638293648-Waiting for file transfers…
0-1638293648-Referencing snapshot on “Eric_MBP” for path “Eric” failed: FAILED
0-1638293648-Waiting for file hashing and copying threads…
0-1638293649-Writing new file list…
0-1638293649-All metadata was present
0-1638293650-Transferred 1.00879 KB - Average speed: 10.872 KBit/s
0-1638293655-Time taken for backing up client Eric_MBP: 50s
0-1638293655-Backup succeeded

The initial backup seems to run OK until it fails trying to access /Users//Library/VoiceTrigger. I have this in my exclusion list but this initial backup occurs before having the ability to add the exclusions via the web console. After this failure I get the messages like above.

Thoughts? Suggestions? More information needed?


Eric Sten

I’m making some progress here. I cleared out my existing client exclusion list that I had built up over time and left it blank. I still got the VoiceTrigger folder warning. I ended up having to add /Users/*/Library/VoiceTrigger to the specific client exclusion list and that allowed the indexing to go through and the backup to run. So I’m guessing the macos_exclusions.txt in the /Library/Application Support/UrBackup Client/var/urbackup folder is not being used. I am running version 2.4.12.

Now I have to add all my specific exclusions back in. At least I saved them. :slight_smile:

1 Like

Hello Eric:

Sorry for not replying sooner on this - I could have saved you some work… :grimacing:

Here’s an unsigned build of the current macOS client codebase:

This refactors the macOS exclusions so they’re all hard-coded into the client, rather than relying on the OS’s now-not-included-and-anyway-it’s-out-of-date Time Machine exclusion list. /Users/:/Library/VoiceTrigger/SAT is one of the included exclusions. Hard-coded exclusions can be overridden if required - see /Library/Application Support/UrBackup Client/var/urbackup/macOS_exclusion_overrides.txt

As the build is unsigned, you might need to right-click and Open the client application after installing it. You’ll also probably need to remove and re-add the client application to the Full Disk Access permission list in System Preferences > Security & Privacy > Privacy.

Please let us know how you get on with this newer build. I haven’t yet updated the exclusions for Monterey - but I suspect they’re not too different from Big Sur.

Hey guys, since I updated to Monterey 12.0.1 I cant add backup paths. I’ll get the message in the attachement. Any thoughts on how to fix this?

HI @lucabrasi

I’ve seen that issue too, but under (IIRC) Mojave 10.14.6. I haven’t yet investigated deeper because (IIRC) you can just OK the dialogue, and then press Command-C to go to the top level of your system and drill down into it as normal.

Hope that helps.

Hi Moisie,
thanks for replying so quickly. I tried to ignore the message and just add a location. Thing is it will not be saved. When I bring up the menu for the locations later it will be empty and Urbackup Admin Interface on the server states that there are no backup path defined. Is there any other way to configure the paths? I was hoping for a config file…

Hi @lucabrasi

Thanks for the feedback. I’ve just tried it on my macOS 12.0.1 system, and it’s working for me as I describe.

I haven’t currently attached it to a Urbackup server - so I wonder if you’ve got yours set to pick up the path from the server rather than use the locally-defined path? What’s your icon at the bottom-right of the Add/Remove backup paths window?

Hm, honestly I was not aware of the posibility to set a mode of path definition at this place. It shows up with the two little pages in the icon on my system. Is there any documentation for those diffentet icons? I can’t find any. I did a fresh install of urbackup and tried the different modes to no avail. And I tried to define one path as a default backup path and still don’t get anything.

Are you using the latest 2.5.x (from post MacOS client 2021 - #76 by uroni I guess) ? On the web interface it shows what they do if you hover over them… (and you should be using a 2.5.x server also)

Yes my client ist 2.5.x but the server ist 2.4.13. I’ll update an report back…

Ok it looks like I’ve reached a dead end here. My server is Windows Server 2008 and I can’t make Urbackup Server 2.5.x run on it. I’ll have to put in some thought on the future of the server before fixing. Or is it whise to run the client for Mac 2.4.x?

Yes - definitely worth trying the 2.4 client. Though it doesn’t have some of the later fixes in it, it did work fine a little while ago.

I am new to URBackup but so far think it’s great. I have a kind of complicated backend setup and am not a developer but am fluent in all of the operating systems I have it running on. The server is running on a fresh install of Debian 11. It’s working fine but I had rebuilt it at a certain point and kept the same name/IP and so my clients got all confused because of the keypair that changed. I have that ironed out on the PC side but not on the Mac side. My mac is running 10.15.7 and looking at the debug info that I got from this thread it’s complaing about the client/server/db versioning mismatch. I suspect it’s just confused about my rebuilding the server so I was hoping I could get some info on how to flush out the client list on the server and Mac client manually. I could not find anything on the Mac aside from the Applications folder that would help. Because it will not run I cannot configure the client on the mac or do anything. I don’t have any settings available to change because it’s not running right-I just get the “there was an error” message. On the server end I suspect it’s all in the database and nothing I can do without being a DB person. I don’t mind testing anything on the mac or server side or clearing all my client/server key pairs out on the server. Thanks in advance, Steve

Hello Steve:

Thanks for posting. I suspect others would be better at advising exactly how deep your clearing out should go, but on the macOS client you’ll find:

  • All the config info is stored in /Library/Application Support/UrBackup Client
  • Logs are stored in /Library/Logs/urbackup_client_backend.log - you may find something of relevance in there.

If you were looking to nuke the installation on your Mac, you should run the Uninstall option from the menu bar icon, then delete /Library/Application Support/UrBackup Client, then reinstall the client - but it may be possible to simply reset the keys - I don’t know about that.

Also please note that updated client downloads are now available in this year’s thread: MacOS client 2022


Wow that is great-exactly what I needed-thank you so much!

Yes, I am aware and had been trying the beta client as well as the 2022 client. Thanks for the quick response and work on an excellent product!