LVM snapshots not removed after successful backup


struggling with LVM snapshots in different topic, I found out, that lvm snaps are not removed.
They are set up correctly, according to what list-backupdirs shows, files are backed up, but then I’m left with remnants of previous backup. Snapshots active, and mounted. I do have to remove/umount them manually.
Log shows (un)successful try to remove unexistent snapshots:

0-1499016339-+ df -T -P
0-1499016339-+ egrep '/mnt/urbackup_snaps/58bedfa373fdf0dc960fb3d9ba32e222a9a290deb9922b5b$$'
0-1499016339-+ echo 'Snapshot is not mounted. Already removed'
0-1499016339-Snapshot is not mounted. Already removed
0-1499016339-+ rmdir /mnt/urbackup_snaps/58bedfa373fdf0dc960fb3d9ba32e222a9a290deb9922b5b

of course is not mounted, because is does not exists. It was not even created during this backup.
Only one of 3 snapshots is removed correctly.
So the question is how to purge old snapshot id database ? Or how to debug this issue further?

I am having a very similar issue with root lvm. Completes successfully and removes all the other lvm except one. have you had any luck figuring out the issue?

the only warning I get is this related message:
Restarting shadow copy of / because it was started by this server

I know that it is a file in /home/users/ that is causing the issue. If I take it out of included directories the / lvm removes when backup is finished. /home/user is a different lvm than the / (root) filesystem that keeps getting left mounted in /mnt/urbackup_snap/name.

I excluded all the hidden folders that usually cause issues such as .wine & .wine64 , I will finally figure out what file is causing it but find it odd that it leaves / snapshot mounted when I never backup anything from that lvm?

I’m afraid I’ve found no solutions to this… I’ve had similar problems with symlinks pointing to locations that should be excluded by design (like /proc/mounts) but were not, but your case might be different.

No, my issue was similar. I have files in my home directory pointing to files on root that are not suppose to be backed up. I could be wrong but when it comes across these files it generates a lvs snapshot of root and then doesn’t remove the snapshot. I would expect this snapshot to never be made in the first place since it is not included in the directories to backup and simply was pointed to by symlink from the directory that is suppose to backup. I hope someone has a solution for this, fix, or explanation. For now I found the directory with the symlink and excluded that folder

Could it be this issue is caused by symlinks to files outside of the backed up paths?

I am not sure I follow, I am pretty sure it is caused by symlinks to files outside of the backed up paths.
What I would like is for the symlinks to backup as symlinks and not concern themselves with what they point to. I do not want every LV that has a symlink pointed to a file on it to cause snapshots to be made of the LV, also if it did cause a snapshot to be created and mounted, then it should umount and destroy snapshot after backup succeeds are fails. Otherwise the system will crawl to a stop from the long sustained snapshots. Then another snapshot is created the next run, exponentiating the problem.
I remedy the issue with excluding my home folder that contain the issues. Not sure why symlink cause issues, but if they did I would expect it to still discard the created LVs and report the error.

Let me know if I am not understanding something, or if there is information I can supply if you fill this is something to look into. Currently at work, but if you need any further information I can supply it in the next day.
Thanks uroni.

You hijacked the thread. This thread is about a bug where snapshots are not deleted with Linux clients.

Again I don’t understand, my Linux clients snapshots are not being removed after the backup completes.

I will stop “hi jacking the thread” and just keep it as I have now so I don’t end up with 10+ snapshots that never go away until I manually remove them. I thought this was a similar issue as already described.

Isn’t follow_symlinks just an option you set?

Hi, I described a similar issue in Cleanup leftover overlay files and snapshots from linux client with no solution so far. @apagr , did you solve your issue ? If yes, how ?
Yours, Steffen