Lost password on Web Gui access in UrBackup in Linux

Hi all.
it’s my fist time in this forum, if I write bad or i’m using the forum in bad way, please help me to do the right procedure.
I have a friend, I installed a UrBackup Linux version 1.4.14. on Centos 6.8 on his PC.
He decided to create a password for a user “admin” (administrator user name) in the web gui access.
He now forget the password :frowning:
I try to access to the db using the sqlite3 command, but the db is encrypted.
there is a way to restore or change the password in this case issue?
thanks for any following answers.

ps. sorry for my bad english.

You can reset the admin password from the command line :

urbackupsrv reset-admin-pw

I don’t have this command in my urbackup version, I tried with “urbackup_srv reset-admin-pw” but the service starts and nothing happen.
the console shows these messages:
2016-11-16 19:00:48: Creating SOCKET…
2016-11-16 19:00:48: done.
2016-11-16 19:00:48: Server started up sucessfully!
2016-11-16 19:00:48: Looking for old Sessions… 0 sessions

what did i do wrong?


On which OS is installed the server ? Windows or Linux ?
The command i give you is for Linux …

it’s LINUX.
maybe the command is in a different path? because if I lanch the command I recive a -bash command not found.

On Debian it’s located in /usr/bin :

root@backup-3:~# /usr/bin/urbackupsrv --help


        /usr/bin/urbackupsrv [--help] [--version] <command> [<args>]

Get specific command help with /usr/bin/urbackupsrv <command> --help

        /usr/bin/urbackupsrv run
                Run UrBackup server

        /usr/bin/urbackupsrv verify-hashes
                Verify file backup hashes

        /usr/bin/urbackupsrv remove-unknown
                Remove unknown files and directories from backup storage and fix symbolic links in backup storage

        /usr/bin/urbackupsrv reset-admin-pw
                Reset web interface administrator password

        /usr/bin/urbackupsrv cleanup
                Cleanup file/image backups from backup storage

        /usr/bin/urbackupsrv repair-database
                Try to repair UrBackup database

        /usr/bin/urbackupsrv defrag-database
                Rebuild UrBackup database

        /usr/bin/urbackupsrv export-auth-log
                Export authentication log to csv file

        /usr/bin/urbackupsrv decompress-file
                Decompress UrBackup compressed file

        /usr/bin/urbackupsrv mount-vhd
                Mount VHD file

        urbackupsrv assemble
                Assemble VHD(Z) volumes into one disk VHD file


My linux version is CENTOS, I installed the urbackup on Centos 6.8, Maybe the commands are different?
I found a similar command " start_urbackup_server reset_pw" but I think that command reset the user “admin” in the urbackup service and not the user “admin” on the web page access : x.x.x.:55414. Becuase I remember that the web access by default is without password, I set the password later.
Could it be a different setting users place store for each service (web and urbackup) ??


I solved the issue.
The command was the right way to do, I missed to use the right parameter:

start_urbackup_server --reset_pw (newpassword)

Thanks a lot for your help TomTomGo.