Login from Restore Client to Backup Server is constantly failing

Hi all,

I just tried to test the restore procedure from one of my backup laptops and experienced problems to access the backup server from the restore client.
Urback Server is running and made already backups from several different clients (both linux and windows). Server ist accessible via SSL webinterface. Everything seems working fine so far (despite the fact I am not seeing any image backups in the backup section although I made several image backups which show up in the log files, too. But this is perhaps a feature, not a bug?).

This is how my setup looks like:
Server: Urbackup Server installed from sources on a Debian Linux 8.0 (Jessie) due to your website instructions
Clients: Urbackup Clients version 2.0.36 -> LAN IP adress (s. below)
Restore Client USB Stick: version 2.0.2 (I also tried version 2.0.3.-2 64Bit with same problems) -> LAN IP adress (see below)

Restore Client seemed to successfully find the Urbackup Server in the LAN and requested user name and user password. I tried to login via my admin account. But instead of showing up the list of available backups I got the error message that login with username and password failed. Of course the user credentials were correct. However there is an error when it asks for the username for the server and then asks me if I want to try again or not.

I switched log level of server to ‘debug’ and will send both logfiles from server and restore client to your mailadress.

I used ngrep ‘’ udp and port 35622 on the restore client and broadcast seemed to work:

root@debian:~# ngrep '' udp and port 35622
interface: eth0 (
filter: (ip or ip6) and ( udp and port 35622 )
U ->
U ->
U ->
U ->

Apparently I am not able to log into the server to restore the image back to my laptop. Why is the username and password that is successfully used for the WebUI not working with the Restore Client?

Thanks in advance for any help!

Hi guys,

for better comprehension I provide the log files both from Restore client and server side.

Content of ‘restore_mode.txt’ -> Restore Client Log

2017-02-10 18:34:32: ERROR: Error setting file permissions to “urbackup/data”
2017-02-10 18:34:32: urbackupserver: Server started up sucessfully!
2017-02-10 18:34:32: Started UrBackupClient Backend…
2017-02-10 18:34:32: FileSrv: Binding udp socket at port 35622…
2017-02-10 18:34:32: FileSrv: done.
2017-02-10 18:34:32: FileSrv: Servername: -##restore##14867516724368-
2017-02-10 18:34:32: FileSrv: Server started up sucessfully
2017-02-10 18:34:32: FileSrv: UDP Thread startet
2017-02-10 18:34:33: Internet mode not enabled
2017-02-10 18:34:33: Looking for old Sessions… 2 sessions
2017-02-10 18:35:34: urbackupserver: No available slots… starting new Worker
2017-02-10 18:35:34: ClientService cmd: #IBWxJDM6PHWD1dvbnQT8w#ADD IDENTITY
2017-02-10 18:35:34: rc=0 hasError=true state=0
2017-02-10 18:35:34: ClientService cmd: #IBWxJDM6PHWD1dvbnQT8w#1CHANNEL capa=0&token=4u9AD55ufVOMW5KRyYic&restore_version=1
2017-02-10 18:35:34: New channel: Number of Channels: 1
2017-02-10 18:36:34: ClientService cmd: PONG
2017-02-10 18:37:33: Internet mode not enabled
2017-02-10 18:37:34: ClientService cmd: PONG
2017-02-10 18:38:34: ClientService cmd: PONG
2017-02-10 18:39:34: ClientService cmd: PONG
2017-02-10 18:40:34: ClientService cmd: PONG
2017-02-10 18:41:34: ClientService cmd: PONG
2017-02-10 18:42:17: urbackupserver: No available slots… starting new Worker
2017-02-10 18:42:17: ClientService cmd: LOGIN FOR DOWNLOAD#pw=LvDXxv5bHsarxxjht7cDuP9VjE3If8
2017-02-10 18:42:17: Waiting for pings…
2017-02-10 18:42:17: done. (Waiting for pings)
2017-02-10 18:42:17: Client 0/1: --err–
2017-02-10 18:42:17: ERROR: Client 0/1 ERROR: --err–
2017-02-10 18:42:17: rc=0 hasError=true state=0
2017-02-10 18:42:34: ClientService cmd: PONG
2017-02-10 18:43:34: ClientService cmd: PONG
2017-02-10 18:44:34: ClientService cmd: GET SALT#pw=LvDXxv5bHsarxxjht7cDuP9VjE3If8&username=admin
2017-02-10 18:44:34: Waiting for pings…
2017-02-10 18:44:34: done. (Waiting for pings)
2017-02-10 18:44:34: Client 0/1: --ok;Ohp5PdglpOhKKnxTFIdJpNLrsGA4JVzWz4zDdXxTMCv3hvDvpu;BofT5UASpe;10000–
2017-02-10 18:44:34: rc=0 hasError=true state=0
2017-02-10 18:44:34: ClientService cmd: PONG
2017-02-10 18:44:39: ClientService cmd: LOGIN FOR DOWNLOAD#pw=LvDXxv5bHsarxxjht7cDuP9VjE3If8&username=admin&password0=56c8b81d4c7999a4603aa571a8d4faff
2017-02-10 18:44:39: Waiting for pings…
2017-02-10 18:44:39: done. (Waiting for pings)
2017-02-10 18:44:39: Client 0/1: --err–
2017-02-10 18:44:39: ERROR: Client 0/1 ERROR: --err–
2017-02-10 18:44:39: rc=0 hasError=true state=0
2017-02-10 18:45:34: ClientService cmd: PONG
2017-02-10 18:46:34: ClientService cmd: PONG
2017-02-10 18:47:34: ClientService cmd: PONG
2017-02-10 18:48:34: ClientService cmd: PONG

Content of ‘restore_wizard.txt’ -> Restore Client Log

2017-02-10 18:42:17: Login Response: err
2017-02-10 18:42:17: ERROR: Error during login: err
2017-02-10 18:44:34: Salt Response: ok;Ohp5PdglpOhKKnxTFIdJpNLrsGA4JVzWz4zDdXxTMCv3hvDvpu;BofT5UASpe;10000
2017-02-10 18:44:39: Login Response: err
2017-02-10 18:44:39: ERROR: Error during login: err

Extract of Content of ‘urbackup.log’ -> Server Log

2017-02-10 18:35:15: New Backupclient: ##restore##14867516724368
2017-02-10 18:41:59: Channel message: LOGIN username=&password=
2017-02-10 18:44:15: Channel message: SALT username=admin
2017-02-10 18:44:21: Channel message: LOGIN username=admin&password=56c8b81d4c7999a4603aa571a8d4faff
2017-02-10 18:46:36: Looking for old Sessions… 1 sessions
2017-02-10 18:57:04: Channel message: LOGIN username=&password=

Any ideas?

Had a look at the log files you sent me and it indicates the password is wrong.

Since you have a German email, make sure you switch z and y when typing the password if any of those are in the password. It currently doesn’t have a keymap selection step :confused:

I interpreted the error messages the same way, but I can ensure there is no typo within the password. So I am rather at a loss. Client and server are communicating correctly? Could it be a problem in the way the encrypted user credentials are exchanged between server and restore client?

Sorrrrrryyyy! I must confess I was a bit hasty with my assurance - it was indeed a typo due to keymap. Unfortunately I only had the most famous example of the letters z and y in mind, but of course there a some more letters affected … Now I tested it again and it works!

Thank you for your helpful hint!

P.S.: Is it a feature that image backups are only accessible via the restore client and not via the server WebUI? They show up in the logs, I can also see them via the restore client, but I don’t see them elsewhere in the WebUI.