Local and remote servers set-up. Remote Port setting


#1

I have had a local network URBackup server running for so time backing up several clients. I now want an offsite backup server too. I have set up a second backup server which I want the local clients to connect to over the internet as well as the local backup server.

The FAQs state:

To select a different backup server you have to edit server_idents.txt in the directory where you installed UrBackup Client. To authenticate an additional backup server you have to ask the server administrator for the server key (It is shown on the status page) and add this key as an additional row to the server_idents.txt .

I have the server key and the hostname for the internet server (which pings over the internet OK).

However for “reasons” I can’t use the default port (55414) for the internet server. How do I specify to the backup client the port to use for this servers in the server_idents.txt?


#2

Hi

You don’t, the port is in the client config, next to the internet server adress.

What should work is to just specify the internet server adress in bother server config ( via the web ui), just type the same address in both.
Because the server copy theses server setting. if you set up the address only on one server, when the client will connect to the other server with empty internet server setting , it will forget that there s an internet server.
But if you type it in both , you shouldn’t have anything to setup on the client for the connection to work.

On the authentication side, the simplest if you have two servers.
Is to use the same server private/public keys on both (lookup the doc for which files to copy).
Else you need to go on each client and copy the server public key in the server_idents.txt.

That way you install a new client, it is autodetected by the local server, and automatically copy the public key.
Because the internet server is configured on the local server, the client will try to connect to it.
Because the key is the same the authentication will also work (nothing to do).
You ll still have t configure the backup settings on both, and they can be différent.

That may sound stupid, but remember the internet settings are in the internet tab, not the server tab


#3

OK - thanks for that. It seems to be working now.

There was some strangeness when I kept updating the client internet settings and the host name kept getting blanked out and port getting reset to the default 55414 and I kept on having to re-enter this. But it then suddenly started working after I left it a while.

I think I also had to manually add the client to the remote internet server too to get it working, I will double check this when I add the next client (just testing with a single client for now). I also set the “Connect to Internet backup server if connected to local backup server:” option on both the servers.