Linux Client Restore does not work 2.0.20

I can not restore a linux client… :frowning:
only errors,…
client: 2.0.20 debian 8
server: 2.0.24 debian 8

  • 2016-06-01 21:20:14: ClientService cmd: #IgBscp4XCLEwZysPRdwvJ#FILE RESTORE client_token=Go+0acLHFSR10UNKgI8QYHFixaU1suAT4F/G3+SNvjBVM225QyyQ3pX8Js9dTDAbS+VbXdnquoVk&server_token=CprjLYeYBlQpTYHz7Gbx&id=7&status_id=3&log_id=4&restore_path=root%2Fbin&single_file=0&clean_other=1&ignore_other_fs=1&tgroup=0&clientsubname=
  • 2016-06-01 21:20:14: ERROR: key.CprjLYeYBlQpTYHz7Gbx not found in urbackup/
  • 2016-06-01 21:20:14: Starting restore…
  • 2016-06-01 21:20:14: rc=0 hasError=true state=0
  • 2016-06-01 21:20:14: ClientService cmd: #IgBscp4XCLEwZysPRdwvJ#1CHANNEL capa=4096&token=CprjLYeYBlQpTYHz7Gbx&restore_version=1

Plase add a command line option to: ignore the (if i’m doing a bare metal restore there is no
i fiddled around nearly 4 hours for this…
please also add an option to continue restore on errors… if i restore a linux client into a fresh “running” system there will be always errors

PS: How is the Pathmapping supposed to work? i can’t figure it out

I will try to embed it into the Linux client download. That already has the root access token, otherwise you cannot get far, either.

There also is a login with username/password mode for which the user interface is not implemented yet.

Mapping should work like this:

urbackupclientctl restore-start -b last -p root/bin --map-from /bin --map-to /tmp/restore/bin

just to be clear here…
i figured it out what was missing…
you have to run a backup first. that will generate the
then you can start a restore with RESTORE=server-confirms

Will test it this evening with restoring the system from a live cd…
would -p root --map-from / --map-to /tmp/restore/ work too?

so i tried to restore via knoppix live cd… no luck at all
client stuck at

2016-06-02 19:01:27: Client timeout in ClientConnector::Run
2016-06-02 19:01:28: ClientService cmd: #IgBscp4XCLEwZysPRdwvJ#1CHANNEL capa=0&token=9GEmZcGDLmsABMNH17BG&restore_version=1

there are really some bare metal recovery functions needed for files… something that starts like the rescue CD but restores files…

Thanks for testing that. Will do some testing myself. Clearly that area needs some more attention.

aaaand the next one…
urbackupclientctl restore-start -b 450 -d / --map-from / --map-to /restore/ -n
map does not work…
it simply ignores it and restores the files to /root/
and in the middle of restoring it switches to / and kills the installation again… :frowning:
doing subdirs does not work either…
server tells it cant find /bin
i think it just removes the root/

what i have found until now:
directory symlinks do not work on restored… they are restored as directories and not as links.
think the same applies to file symlinks…
there is no continue on error function. if it runs into an error the server stops sending data and the client sits there forever waiting.

as that server is essential to me i’m willing to test everything you can throw at me to restore it…

i think the most important thing is that the server handles backed up symlinks correct on restore.
where it actually restores does not matter as long its a subdirectory on the client where i can mount the filesystem

Situation should be much improved with 2.0.26/2.0.22.

Will test it tonight

still unable to restore…

2016-06-08 11:35:19: ClientService cmd: #IgBscp4XCLEwZysPRdwvJ#FILE RESTORE client_token=bK/+HYM9FIbQxrh7Xaw0NlMDZOoNWNCmkE1FWRADg5u3OP9Ib0KFH4nOkHcvJUWL47Pr5xhndmIg&server_token=D3mrcNC8jJcaW60huSLV&id=8&status_id=7&log_id=10&restore_path=root%2Fglftpd&single_file=0&clean_other=1&ignore_other_fs=1&tgroup=0&clientsubname=
terminating with uncaught exception of type CryptoPP::HashVerificationFilter::HashVerificationFailed: HashVerificationFilter: message hash or MAC not valid

Nevermind… fixed it… crypto++ was not installed…
had to run the client in gdb to see the error… nothing was logged at all. just crashed silently…