Linux client problem with backupdir settings


#1

This is for a Linux client v2.0.30.0.

I’m trying to setup several backup paths for a single client. I’m using the urbackupclientctl program to do this. It appears to reset already configured paths to the default options when adding new paths.

#urbackupclientctl add-backupdir -x -f -d / -n root
#rbackupclientctl list-backupdirs
PATH NAME FLAGS
---- ---- ---------------------------------------------
/ root symlinks_optional,one_filesystem,share_hashes

So far looks good, right? I then add the second path:
#urbackupclientctl add-backupdir -x -f -d /boot -n boot
#rbackupclientctl list-backupdirs
PATH NAME FLAGS
----- ---- ----------------------------------------------
/ root follow_symlinks,symlinks_optional,share_hashes
/boot boot symlinks_optional,one_filesystem,share_hashes

It looks like it’s reset the options on the first path to the defaults. I haven’t let it run a backup like this, because I really don’t want it to span filesystems.

Which brings up a related question. In the documentation it is stated that flags are specified by appending “/” to the path. How does this work with Unix paths? /usr/local/one_filesystem doesn’t seem correct. Should it be \usr\local/one_filesystem?


#2

Could you try if it is fixed with 2.0.31? Linked from the forums here.


#3

Unfortunately it does not seem to be fixed in 2.0.31.

#urbackupclientctl --version
UrBackup Client Controller v2.0.31.0

#urbackupclientctl add-backupdir -x -f -d /boot -n boot
#urbackupclientctl list-backupdirs
PATH NAME FLAGS
----- ---- ---------------------------------------------
/boot boot symlinks_optional,one_filesystem,share_hashes

#urbackupclientctl add-backupdir -x -f -d / -n root
#urbackupclientctl list-backupdirs
PATH NAME FLAGS
----- ---- ----------------------------------------------
/boot boot follow_symlinks,symlinks_optional,share_hashes
/ root symlinks_optional,one_filesystem,share_hashes


#4

It looks like the following syntax might work (setting up from within the web GUI):

Default directories to backup: /home|User Files/one_filesystem