Linux client discovery works on a laptop, fails on a desktop


Successfully installed urbackup server (ubuntu 16.04) and linux laptop client (GalliumOS, based on Ubuntu 16.04) yesterday. After a bit of firewall tweaking on both server and client I managed to do a full file backup and today an incremental file backup. Discovery didn’t seem to work until I provided an ip address hint however.

I next tried my desktop, which is a tri-boot hackintosh (osx/ubuntu/windows) whilst running OSX. Again, discovery only happened after providing a hint, but also the transfer was excrutiatingly slow - estimated 3 months for full file backup =D - so I abandoned that backup and rebooted in Ubuntu Gnome 16.04 in order to check it was a problem specific to OSX.

However, even with a discovery hint the server is not finding the desktop when running Ubuntu.

Is this because it’s a multi boot machine? Is there some urbackup security feature preventing another client with the same mac/ip address from working?

ufw is disabled on the desktop…" iptables -L" is thus empty. urbackupclientbackend.service is enabled and active. Really cant understand why the server cant see it.

The only other difference is that the laptop works over wireless and the desktop over ethernet. I should add that the server connects to the network over a bridge br0 via the em1 interface, but since it can reach the laptop through that I can see how that is the issue.

Any ideas?

Have you checked the logs?
There’s bound to be a hint there…

Nothing obvious in /var/log/urbackup.log on the server. I’ll need to reboot to check the client side.

And nothing in /var/log/urbackupclient.log on the unseen ubuntu client.

When I try to manual start a backup on the client:
sudo urbackupclientctl start --full --client

response is:
Error starting backup. No backup server found.

Really looks like the client and server can’t see each other. Given the other machine and OS are seeing it I think I have to assume its something about the networking on this ubuntu install. Will look into it further.

Well, I’m at a loss. Even checked the router to see if it was blocking LAN traffic. Might just need to look at a different solution for backup.

Have you ran the server in debug mode?
The logs are a lot more informative.

I have checked debug logs. Looks like it may be having issues around the dual boot nature of this desktop, treating ubuntu as though its osx and then complaining about not being able to get the file list.

Tried removing the osx client and setting up a fresh client while booted into ubuntu. Still not working. Tried switching to ‘internet’ backups - this point it was able to add the ubuntu client but still unable to actually run a backup (either via the command line on the client of the web UI on the server).

I think I’m going to look at client side solutions instead, that simply use the server as a storage location.

Thanks for you help.