[Linux client 2.3.4] How to disable LVM snapshots and Use no snapshot mechanism? Deleting snapshot.cfg doesn't work (empty the values doesn't work either)


#1

Hi,

Environment
Linux client: UrBackup Client Backend v2.3.4.0
Linux client OS: CentOS release 6.6 (Final)
Server: UrBackup Server v2.3.7.0
Server OS: Debian


I’m trying to make the “no snapshot mechanisms” to work:

At first, I installed the client with option “2) LVM - Logical Volume Manager snapshots” but it did not work.
Then I performed the installation again and I used the option “4) Use no snapshot mechanism”.
Now the backup seems to have executed something but the server (Web UI) shows “0 bytes”.


SERVER-SIDE backup logging while running backup that results in 0 bytes:
23/02/19 16:03 INFO Referencing snapshot on "linux.client" for path "cgi-bin" failed: FAILED
23/02/19 16:03 DEBUG Loading file "cgi-bin" (metadata only)
23/02/19 16:03 INFO Referencing snapshot on "linux.client" for path "moodle" failed: FAILED
23/02/19 16:03 DEBUG Loading file "moodle" (metadata only)
23/02/19 16:03 INFO Referencing snapshot on "linux.client" for path "nagios" failed: FAILED
23/02/19 16:03 DEBUG Loading file "nagios" (metadata only)
23/02/19 16:03 INFO Waiting for file hashing and copying threads...
23/02/19 16:04 DEBUG Saved metadata of 1 files and directories. 22% done...
23/02/19 16:04 INFO Writing new file list...
23/02/19 16:04 INFO All metadata was present
23/02/19 16:04 DEBUG Syncing file system...
23/02/19 16:04 INFO Transferred 2.82422 KB - Average speed: 21.904 KBit/s
23/02/19 16:04 DEBUG Script does not exist urbackup/post_full_filebackup
23/02/19 16:04 INFO Time taken for backing up client linux.client: 1m 10s
23/02/19 16:04 INFO Backup succeeded

CLIENT-SIDE backup logging (small sample of: /var/log/urbackupclient.log) while running backup that results in 0 bytes:
ERROR: Creating shadowcopy of "bkp_scripts" failed
ERROR: Creating shadowcopy of "conf" failed
ERROR: Creating shadowcopy of "html" failed
ERROR: Token id for user "root" not found
ERROR: Token id for user "bin" not found
ERROR: Token id for user "daemon" not found
ERROR: Token id for group "tcpdump" not found

What I’ve tried so far:
I deleted the: /usr/local/etc/urbackup/snapshot.cfg
I created the file (but I ended up deleting because it had no effect.): /usr/local/etc/urbackup/no_filesystem_snapshot

I restarted the client (urbackupclientbackend) to see (ran the backup again) if it had any effect, but had no effect.

Settings I’m using:
SERVER-SIDE (Web UI) configured options:
Separate settings for this client (enabled)
Excluded files (seems to work)
Included files (doesn’t seems to work)
Default directories to backup (seems to work)

CLIENT-SIDE:
RESTORE=server-confirms (/etc/sysconfig/urbackupclient)
exclude_files_def (_/usr/local/var/urbackup/data/settings.cfg) options correctly filled by the server
default_dirs_def (/usr/local/var/urbackup/data/settings.cfg) options correctly filled by the server


Any help in getting the “no snapshot mechanisms” backup to work is very welcome!!
Thanks!


#2

What do you have include dirs set to? Usually using include dirs is not necessary…


#3

My intention was to include the directories that would be part of the backup. But since it did not work, I’ve included directories in the Default directory option.


#4

Please set the include dirs to empty. If you set them to a incorrect value, nothing gets included in the backup and you will end up with a backup with no files in it.


#5

Thanks uroni! It worked!

Leaving the “Included files” field empty (relative to the linux client options in the server Web UI), the backup worked.

I kept my values filled out in the “Default directories to backup” field.

What would be an example value that could be placed in the “Included files” field?

In the “Excluded files” field could a valid value example be like this?
/opt/openfire/logs;.DS_Store;._.*


#6

The example in the FAQ https://www.urbackup.org/faq.html#include_files would be a valid use case.