Linux backup with both LVM and disk partitions failes


#1

Hi,

I’m using uBackup to create file backups of several Linux servers. Most of this goes fine, however, I do have one small annoyance.

The filesystems of these servers are all created on LVM, except for 1: /boot; this one resides natively on the disk partition.

Now, whenever I try to backup this server, I get the following errors in the log:
Errors 03/20/17 12:46 Creating snapshot of “/boot” failed
Errors 03/20/17 12:46 Volume group “xvda1” not found
Errors 03/20/17 12:46 Cannot process volume group xvda1
Errors 03/20/17 12:46 Could not find LVM volume group of volume /dev/xvda1
Errors 03/20/17 12:46 Creating snapshot of “boot” failed.

The files in /boot are backed up, but is there a way I can tell the client to not try and create a snapshot for /boot?


#2

Try to edit the pre/post scripts like :

/usr/local/share/urbackup/lvm_create_filesystem_snapshot
and files in
/usr/local/share/urbackup/


#3

Thanks. I’ll give that a try.


#4

I am having the exact same issue. What exactly needs to be edited in those files?


#5

you d need to add a condition to ignore /boot or on lvm partition or not error on this.


#7

Can you give me advice on how to do this?


#8

I emptied it to disable snapshots, and can t find it on github
What does /usr/local/etc/urbackup/snapshot.cfg looks like ?


#9
#This is a key=value config file for determining the scripts/programs to create snapshots

create_filesystem_snapshot=/usr/local/share/urbackup/lvm_create_filesystem_snapshot
remove_filesystem_snapshot=/usr/local/share/urbackup/lvm_remove_filesystem_snapshot

#10

Hi

Apparently there’s no need to edit the script, the backup isn t actually in error.
I tested and unless the “require-snapshot” is set the backup shouldnt fail if snapshots aren’t possible. And the client isn’t in error status.


#11

It actually backs up the /boot folder, but says completed with errors, so everytime you have to click on it to check the errors. If i could turn off snapshotting of the /boot folder, then it would say OK, and I wouldn’t need to check it everytime.


#12

Hello,

any solution to this non LVM backup errors?

thanks


#13

echo /boot > /etc/urbackup/exclude_snapshot_mountpoints