Issues with groups and settings

Hi, someone please let me understand something.

I have a backup group with “Do image backups over internet” and “Do full file backups over internet” turned ON.

I also have a host inside that group who has both these options OFF and greyed out. The host won’t backup over the internet and i cannot move it to the server’s network.

Host does not have “Separate settings for this client” so it should use the group’s settings, right?

Moving the host into a different group (and back) does not seem to change anything.

UrBackup 2.2.11 server on Centos 7 and client on Win10 if it matters.

Have you tried yousing “Seperate settings for this client”? I’ll find it at your first picture.

No, on purpose.

If the client does NOT have separate settings, why does it not take group settings? Furthermore - it takes some settings from group, but not these two.

Settings have probably been modified on the client and you have “Allow client-side changing of settings” enabled.

That sounds possible. I might have had it allowed at some point, but not any more.

How do I “reset” the client to defaults? It seems i have reached some kind of impasse. (entirely deserved for fiddling with the settings, i suppose)

As the client does not seem to want to connect in “internet” mode or the server does not let him, i cannot do anything. Client status is “Connected to internet server”, server says that last seen yesterday. Urbackup settings not available in client GUI.

If you have “Allow client-side changing of settings” disabled the setting is identical to the group setting if you do not have “Separate settings for this client” enabled.

Well. The trouble is that i can put “Allow client-side changing of settings”, but the client will never know it, because he connects in internet mode and does not get that this info has changed. And somehow - as you can see from the pictures, they are note identical to group settings. Somehow the server side settings for this client and client side settings have become conflicting and neither one is willing to communicate with the other.

Anyway, solved it so that uninstalled the client, cleaned up everything i could find, checked “Separate settings for this client”, installed again on the client and voila!

Thank you for your effort anyway. Is there an easier way to just reset conf on the client side and tell it to reintroduce itself to the server? The server does not consider client settings if that setting is disabled + The server starts backups, not the client.

I understand that, but somehow the server side start failed.

For me, client seemed to be of the opinion that it SHOULD NOT communicate over the “internet” and it COULD NOT communicate locally (different network). Server was of an opposite opinion and probably wanted to communicate locally and client was therefore offline for him.

Nothing worked until I did a cleanup on client and reinstalled.