Is there any other restore utilities?

I know about the command line, but I need an easier, cleaner way to restore.
I really like urbackup so far, only after a few days of use, but the restore is clumsy at best, and that said trying to be nice.

I’m using the latest restore (2.3.1) and it just doesn’t work right.
I finally got it to get the the actual restore process, and it gets to 12 percent, then shoots up to 100 percent. Then goes to:

Loading MBR for hard disk…
Restore to mbr.dat
ERROR: connection timeout
WARNING: Read timeout: retrying -1

Then asks to retry and cannot find the server anymore, even though I can ping from server to client and client to server.
I have to reboot the client and start over.
Did this 3 times and always the same result, using two different images.

So what do I do with this? Is there a restore disk version that doesn’t have any problems? Maybe the newest is still “beta-ish”?
Has anyone used the restore with NO problems at all?

Yes, I have used several versions of the Restore CD on several sets, typically with no problems at all. Release versions (downloadable from are well tested and not “beta-ish” in any way. The only development versions are found in the Testing forum so you must make a special effort to install one.

Things which may help you:
Some BIOS software tries to protect against malware by making it difficult to modify the MBR of a disk. Check for this and disable if present.

Errors on the disk drive may prevent successful updating of the MBR. Fixing your hardware is outside the scope of UrBackup.

Sometimes a drive is so scrambled UrBackup cannot make sense of what is there. Use a drive erase utility to wipe at least the first gigabyte and last gigabyte of the drive and try the restore again. I have needed to do this on at least one system.

I got all 9 pc’s backing up and restoring as of yesterday.
Turns out there were 2 errors that were causing the restore failures.
One pc had errors on the restore partition. This was the one that would give me the connection error stated in my previous post. Once I fixed the bad partition, it restores perfectly.
The other pc actually had 2 listings of a backup for the same time, this may be a bug?
If I tried to restore the first listing, it would fail every time. Once I noticed the second backup listing was from the same time, I tried it and it restored perfectly.