Is there a way to disable server_ident security?

I run UrBackup on TrueNAS Scale, everytime my host reboots, the ID changes for the server, however this is presenting an issue where everytime it reboots, it kicks all my clients offline because of the server_ident key being regenerated.

I know I can save the key and edit it everytime but it’s a pain, is there a way to just disable this all together?

Sounds like TrueNAS maybe not storing the file correctly, as i would assume if the server ID file doesnt exist it creates a new one. Could this be TrueNAS does not have write permission on that directory? We have it running on QNAP and not seen this issue