Internet Image restore


#22

Great news! I deleted a bunch of files after I made my internet image backup and then did a restore and it was successful. Thanks to @uroni excellent work. Maybe this isn’t as exciting to you guys but this means that I can trust this as an image backup for my PC’s over the net.


#23

It would be very cool if I could figure out why there isn’t a status of the restore while it’s happening. All I could see was the percentage that had been done so far. There wasn’t a bandwidth usage or anything either. Is this something I need to configure or is it just not available/possible yet?


#24

Hi there !

I’m sorry if this is not the right place to ask, let me know and I’ll create a new thread… Well, I have a windows computer with a broken hard drive and I was backing it up via internet and image backup with 2.1.20 server and 2.0.36 client, the backups seems alright so I would like to restore the system on the new hard drive I installed on the computer.
I boot with the urbackup_restore_2.1.1 iso (on usb pen) but I struggle to launch the recovery…
I see there is an option to connect to internet server but I can’t manage to make it connect, sorry if the solution is obvious but I really have issue to find how to authenticate :disappointed:

Every time I enter the server address and port, then I have to provide the Internet server restore authentication key and that the issue, I don’t know what it is !
I looked on the user folder and found a lot of files, maybe I have to write some informations on some files ? What I tried with no success is to copy the server_ident.key I found on the server, I removed the preceding ’#I’ and ’#’ at the end of the contents of ’server_ident.key’ as I found in the documentation with no luck…
I also tried with the internet auth key that can be found in the settings/client section on the webpage with no more success…
I fact I don’t understand why I have to provide this key in place of the username/password (or I imagine it would be the next step since I saw the text that ask it in a file in folders of the restaure image…)
Every time I have the following message : “following error happened: authentication with internet server failed with status error : authentication failure : unknown client (##restore##jkjkgsbgjkregh4567)”

Please can someone tell me the steps I have to do ? Do I have to write some IDs in some text files on the client ? I’m sure I’m not so far to make it work but I tried so much combinations since hours with no result ! :sweat:

This computer is very important there is unique data and piece of software and configs and so on… and I can’t get it back without this restore… thank you very much for your help…


#25

On the web ui, go to setting, select the client, go to internet tab , look for “Internet auth key”.


#26

Hi !
Thank you very much for your answer ! and so fast !
sadly I already tried this (look in my message when I say (I also tried with the internet auth key that can be found in the settings/client section on the webpage) but it give the authentication with internet server failed with status error : authentication failure : unknown client message…
Of course I tried many times to be sure to well respect uppercase and lowercase…

Do you have another idea ? Maybe I could write it in some file ?

thanks


#27

You need to install the 2.2.x (beta) server. Then it shows (or you can configure) the restore auth key in the general internet settings.


#28

Thank you very much for your answer, I will try your solution as soon as I can ( tomorrow morning ) and I’ll come back to confirm that this solution has worked!
Thanks again for your quick answer :slight_smile:


#29

Hi there !

I upgraded the server as you told me to and it seem to work, I have been able to log in browse in all the backups and launch the restore process ! sadly, the hard drive I wanted to restore on is a little bit less big, big enough though because the last one was containing less data than the size off the new drive but it appear that restoration to a littlest disk is not supported… or maybe there is a way ?
Anyway, thank you very much for your help ! the initial issue is corrected, I will try to find an exact same size drive and try again, if it works it will be a big big up for you and your work because the new restore iso including is so much simpler than the older one witch was almost not possible to manage it !
Thanks again, Il’l come by to tell if I manage to successfully restore when I’ll have changed the HD !


#30

Hi there !
BIG BIG UP to UrBackup !!!
With these new versions, restoration from scratch of a windows machine worked like a charm and extremely easy, after having updated the server to the last beta version, with the “global” internet auth key and get a same size hard drive the restore perfectly worked as expected, then the machine booted, load the new HD drivers and that’s it !!
Everything is perfect ! Even the files in the trash bin are there lol ! So for me the question is considered as solved !
I’m so happy, a big thank you to urbackup, and its dev(s) of course !