Internet backups not running if remote client is on the same subnet as internet backup server

URBackup server 2.4.13 running on linux
Clients are all windows running 2.4.10 URBackup client.
Server is on an office network with outside static IP address 96.x.x.x. This Internal IP address is static
Local backups have been running great for quite some time (thanks for the great software!)
I have enabled internet backups and they are running EXCEPT when the client computer is outside the office on another 10.0.0.x network. In which case the client says it cannot locate the local server or the internet server. If the client is remote on another network such as 192.168.x.x or any network other than 10.0.0.x, then the remote backup works.
On the server settings, the server URL is set to the outside IP address, http://96.x.x.x:55414 and port 55414 is forwarded to 10.0.0.x The internet server Name/IP is set to 96.x.x.x and the port is 55415 is forwarded to 10.0.0.x
I did try enabling the internet backup setting “Connect to Internet backup server if connected to local backup server” but that did not make any difference. I’m sure there must be a way to solve this without changing the subnet of the urbackup server or the clients when remote, but I am not finding a solution. Thanks for any help.

Please verify on the server Settings: (Client_Name): Internet you have Enable internet mode: checked and the appropriate backup types (file or image) checked.

How did you create these Internet clients?

Once you have your server configured as you stated above, the safest way is to use the + Add new client button at the bottom of the Status page to create a placeholder with the new client name. This does not have to match the local name of the computer, it is just a unique label so you know which client it is. After that, login to the server admin web page (http://server.ip:55414) from the remote client, download the custom UrBackup Client installer for that client name from the Download client for Windows (or Linux) drop-down menu, and install it. This creates a client installation with the correct Internet settings for your server, and should be ready to go.

Pro tip: Logging into the server from the remote client verifies the connection between the two, at least for that one port. If this doesn’t work there may be errors in the setup for the other port (55415) as well.

I have doublechecked, and internet backups is enabled with file backups checkmarked.

All the clients were initially added when local to the server by installing the generic URBackup windows client software. The server then auto-discovered all the clients and local backups commenced with no problems. Internet backups at that point in time were not enabled on the server.

I don’t have any new clients to add, but I did download from the server an existing client installer, removed the existing URBackup software from the windows client (I have remote access to it), rebooted, and installed the URBackup client using the custom installer downloaded from the server. The internet backup did start working on the client then. I was hoping to avoid having to re-install the client software on each client, but this will work if I don’t find what else could be the problem.

Thank you for replying and sending me in the right direction!