Install last UrBackup on CentOS6


#1

Why is CentOS6 unsupported as a backup server ?
I can not find a valid repo here: http://download.opensuse.org/repositories/home:/uroni/
I tryed to use CentOS7 repo but with no luck.

I was able to install UrBackup using this repo: http://download.opensuse.org/repositories/home:/kot1grun/
But the version od UrBackup is 1.4.14 :frowning:


#2

don’t lose your time with 1.4.14

I am having no problem downloading the file, didnt tried to install it

http://download.opensuse.org/repositories/home:/uroni/CentOS_7/x86_64/
http://download.opensuse.org/repositories/home:/uroni/CentOS_7/x86_64/urbackup-server-2.1.20.2045-2.1.x86_64.rpm


#3

I tryed:

Error: Package: urbackup-server-2.1.20.2045-2.1.x86_64 (home_uroni)
           Requires: systemd
Error: Package: urbackup-server-2.1.20.2045-2.1.x86_64 (home_uroni)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: urbackup-server-2.1.20.2045-2.1.x86_64 (home_uroni)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: urbackup-server-2.1.20.2045-2.1.x86_64 (home_uroni)
           Requires: libcurl >= 7.20.0
           Installed: libcurl-7.19.7-53.el6_9.x86_64 (@updates)
               libcurl = 7.19.7-53.el6_9
           Available: libcurl-7.19.7-52.el6.i686 (base)
               libcurl = 7.19.7-52.el6

#4

Haa, i didnt paid attention to the important part , centos6 , not 7

Did you tried the docker, if you never used docker before, that may be a little rough way to start.

Run UrBackup Server in a docker container via
docker run -d --name urbackup-server-1 -v /media/backups:/backups -v /media/database:/var/urbackup -p 55413-55415:55413-55415 -p 35623:35623/udp uroni/urbackup-server

this will map /media/backups from the real server to /backups in the docker context , same idea for the ports, and everyting with a : separator

If needed you should be able to get the docker id via “docker ps” and then enter the docker context via "docker exec -it xxxIDxxx bash"
But really all operations should work via the web ui.


#5

I will try the Docker container.

Have you ever tried to use it ?


#6

We run urbackup in docker, but it s hand made one, i never tried this specific one.