Incremental image backup fails on Windows 2016 Server client

Automated incremental image backups keep failing on a Windows Server 2016 client that’s hosted in Azure. The Incremental file backups are working fine. The error is below:

Backing up System Reserved (SYSVOL) partition failed. Image backup failed

Debug log on the client didn’t reveal anything related to the SYSVOL.

Manual incremental image backup work just fine. The client is running version 2.1.16. The UrBackup Server, latest Debian Linux, also in Azure, is running server version 2.1.19.

I have just learned of the “sysvol_test.exe” utility on Windows clients, and running it reveals the problem:

C:>“C:\Program Files\UrBackup\sysvol_test.exe” /?
Filesystem. Vol="\?\Volume{9679c300-0000-0000-0000-100000000000}" Name="" Type=“ntfs” VPaths=1 Size=136363110400
Filesystem is System partition. Skipping…
Filesystem. Vol="\?\Volume{7d7cbdf4-0000-0000-0000-010000000000}" Name=“temporary storage” Type=“ntfs” VPaths=1 Size=8588816384
Bootable flag not set for volume
Filesystem. Vol="\?\Volume{487bbd7d-f78e-11e6-a941-806e6f6e6963}" Name="" Type="" VPaths=1 Size=-1
GetVolumeInformation failed with error code 21. Skipping…
Filesystem. Vol="\?\Volume{487bbd7c-f78e-11e6-a941-806e6f6e6963}" Name="" Type="" VPaths=1 Size=-1
GetVolumeInformation failed with error code 21. Skipping…
Found no SYSVOL on the same physical device as ‘C’.
No sysvolume found.
Trying to open SYSVOL()…
Could not open SYSVOL(). Last error=3
System dir: C:\Windows
Volpath: \.\C:
Device is not GPT formatted (0)
Found no EFI System Partition
No EFI System Partition found.
Trying to open EFI System Partition()…
Could not open EFI System Partition(). Last error=3

I confirmed in Disk Manager and there is no SYSVOL volume. How do I make the automated incremental image backups skip the SYSVOL? The server is set to backup ALL_NONUSB volumes. Do I just add SYSVOL to be ignored somewhere?

Thanks for a great product!

Of course it handles the case where there is no sysvol.

There is essentially no difference between a automatic and manual backup, so I guess you just have transient connection issues.

There is essentially no difference between a automatic and manual backup, so I guess you just have transient connection issues.

Two servers in Azure, both in the same region, and you’re telling me, sorry, connection issues? I’m having a hard time accepting that. I can run a manual incremental image backup immediately after the automated one fails and it works. So there is some difference.
What else can I check? What other built-in tools or logs can I use? Is anyone else running their server or client in Azure and seeing anything similar?

Since you posted no log files, all you get is speculation. Sorry.

Do you prefer logs, and I assume the debug logs, posted here or emailed to you?

Since I had to restart the service after enabling debug logging on both the server and the client, I will have to wait another 24 hrs for the automated incr image backup to kick off. So far, two manually-triggered incr image backups worked just fine. I can also post the firewall configuration for both the client and the server, if that will help?

Emailed debug logs from server and client to
Also, the successful incr file backup takes place minutes before the failed incr image backup, so I’m having a hard time with it being a connectivity issue.

And here are the firewall rules setup on both the client and the server.

UrBackup Server Outbound Rules:

UrBackup Server Inbound Rules:

UrBackup Client Inbound Rules:

UrBackup Client Outbound Rules:

Since you posted no log files, all you get is speculation. Sorry.

I believe that I have now provided all of the information I can think of, so hopefully I will get more then just speculation.


It’s an unstable network connection.

OK, that’s disappointing. I guess Azure is not a good solution for hosting a UrBackup server then.

I would love to hear from others that are running a similar solution, or have seen similar issues.

I having a little trouble with your conclusion uroni. Here is why:

  • Automatic incr image backup has never worked. Not once since installing the agent. The network cannot be permanently unstable. I suppose I could try setting up a VPN between the two VM’s in Azure. Thoughts?
  • Manual incr image backup works fine. If unstable network was the issue, why does it work when I fire it off manually?
  • Automatic incr file backup works fine, from day one. If the network was unstable, why would it work? Shouldn’t the file backup have issues just like image backups do?
  • I do see the agent showing as not online in the web ui occasionally - how does the server determine if an agent is online or not? It seems to go back online once I restart the service on the client machine.

What else can I do, other than the firewall ports, to make sure that it shows online? Does a logged on user make a difference? If no one is logged onto the server, it means that the tray app is not running - is that the reason for agent showing not online?

I now have 3 different clients backup to the same Azure-hosted server: two Win10 workstations in 2 different location, and one Server 2016 in Azure. Incremental File Backups are running without issues. Incremental Image backups are still failing randomly. Clients frequently appear offline in the server web console. If I restart the UrBackup service on the client, it then appears as online on the server and I can trigger an incremental Image Backup and it will complete successfully, but anytime the scheduled Incremental Image Backup runs, it fails.

I have setup virtual peering in Azure between the server and the client both hosted there. They can now talk to each other over the local LAN, as opposed to go out over public Internet. This has not solved the issue.

I need some more help with this issue. I can’t be the only person experiencing this problem. I have provided debug logs, examples, firewall rules screenshots. What other info can I provide? What other troubleshooting steps can I perform? Since I don’t know the inside workings of the backup server, and I have asked for more information and not received it , I don’t know what to test next. I’m an IT guy by day, so I’d like think I understand the basics.

I would really like to get this working, if I am to use this backup solution in production. I plan on offering backup for money and right now the product is not working for me. I’m happy to buy the commercial license for the Change block tracking and contribute financially to the development of this product, but I do expect to receive support as well.

You could use e.g. Wireshark to have a look at the raw network connections

It would appear that I’m a victim of Azure’s default feature:

There are some tweaks that can be done at the kernel level of the underlying Virtual Machine. I will test and report.

I have made changes to the above parameters both on the Linux UrBackup server and on the Windows Server 2016 client, both hosted in Azure. I will report any changes in the next few days.

Thanks for the update!

I’m thinking about somehow saving/detecting if a client has a “unstable connection” and decreasing keep-alives and timeouts in such a case.

Currently the keep-alive interval is 5min, btw. We had one person with a cisco firewall that killed connections after 10min, but that was the minimum that I have heard of till now.

Just an update. After making changes to the Linux OS where the UrBackup server is running, as described in the post above, both File and Image backups work for multiple locations, as long as they are not on Azure. The one Windows Server in Azure will still not do scheduled Image backups, but it runs File backups just fine. I’m OK with that. Not like I’m going to upload an entire hard drive image to Azure, plus we have redundant backup with CrashPlan and Azure Backup. But my Work laptop does scheduled Image incremental backups both from the office and home (Yay!), and one additional desktop is running scheduled Image and File backups without errors. (Also worked out how to Exclude some files that shouldn’t have been backed up in the first place - read the manual, go figure).

Just heard recently about CrashPlan cancelling the free Home backup “to a friend” feature, so I’m going to be relying on UrBackup as my primary backup for friends, family and clients. I’m happy that I got the bugs worked out. Hopefully I don’t have to go through THAT again.

Thanks for your support Uroni. We can marked this post as solved, for the most part.